Search Unity

  1. Looking for a job or to hire someone for a project? Check out the re-opened job forums.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

getAxis(Mouse...) returns 0 sometimes after interacting with inputfield

Discussion in 'UGUI & TextMesh Pro' started by holyjewsus, Apr 14, 2015.

  1. holyjewsus

    holyjewsus

    Joined:
    Mar 7, 2011
    Posts:
    624
    I have some input fields in my scene, some are world space, one is screen space. I also have a camera movement script that uses getAxis(Mouse X) that works. When I interact with the input fields sometimes(seems random) I get all zeros returned from getAxis, this is inside the editor. To fix the issue, I need to switch to another window in mac os x or another unity editor view(clicking into the console or hierarchy and then back to game view also fixes it)

    I have not yet tested in a build yet.
     
  2. holyjewsus

    holyjewsus

    Joined:
    Mar 7, 2011
    Posts:
    624
    has anyone else seen this behavior?
     
  3. holyjewsus

    holyjewsus

    Joined:
    Mar 7, 2011
    Posts:
    624
    bump, still not solved, something to do with entering into the input field and possibly still being in edit mode on it?
     
  4. holyjewsus

    holyjewsus

    Joined:
    Mar 7, 2011
    Posts:
    624
    not resolved, totally at a loss as to whats going on here...
     
unityunity