Search Unity

GearVR crash issue with 5.2.0f1 & f2

Discussion in '5.2 Beta' started by tonic, Aug 22, 2015.

  1. tonic

    tonic

    Joined:
    Oct 31, 2012
    Posts:
    379
    I have a test scene which runs fine on 5.1.2p3 with Gear VR S6 using the built-in VR stuff. But the same thing crashes immediately on 5.2.0f1 and 5.2.0f2. Any idea what could cause this?
     
  2. leetful

    leetful

    Joined:
    Feb 23, 2013
    Posts:
    16
    I'm having the same issue going from 5.1.2p3 -> 5.2.0f2, GearVR app crashes on launch.
     
  3. williamj

    williamj

    Unity Technologies

    Joined:
    May 26, 2015
    Posts:
    92
    Hi @tonic

    I will look into this but in the mean time do you mind filing an bug report and posting the case number on this forum?

    Thanks,

    Will
     
  4. tonic

    tonic

    Joined:
    Oct 31, 2012
    Posts:
    379
    Hi Will, I submitted a bug with a mini project. Case number for the bug is 722122.
     
  5. mpgholden

    mpgholden

    Joined:
    Aug 21, 2014
    Posts:
    16
    I'm encountering this as well, with a project originally upgraded from 4.6.3. Works on 5.1.3 (today's release) but not 5.2.0f1. Hadn't tried RC2 yet.
     
  6. tonic

    tonic

    Joined:
    Oct 31, 2012
    Posts:
    379
    Switching to GLES3 renderer works for now.
     
  7. williamj

    williamj

    Unity Technologies

    Joined:
    May 26, 2015
    Posts:
    92
    @tonic

    Right!

    The devs have pinned the problem down to gles 2 and are fixing it up for the next possible update.

    Thanks everyone.