Search Unity

GameCircle - Doesn't log in as the correct user - says you are a guest.

Discussion in 'Android' started by Jason-H, Aug 20, 2013.

  1. Jason-H

    Jason-H

    Joined:
    Nov 5, 2010
    Posts:
    87
    Hi. When I open my app on a device the GameCircle box that pops up near the bottom states that I am a Guest even though I have logged in to my GameCircle account on other apps that use it.

    Other GameCircle enabled apps log me in automaticaly when I open them for the first time as opposed to my app stating that I am a guest.

    On the Amazon devices (Kindle, Kindle Fire etc) there is no "Log in" button available on this white box at the bottom of the window, whereas when I play it on a Google Android device (HTC Desire) the "Log in" button is there to the right.

    How can I have the user automatically log in to GameCircle when they open the app? I don't want them having to click "Log in" when they open the app as it is automatic on other apps.

    I am using Unity 4.2.0f4 with the Unity SDK available from the developer portal. Leaderboards work correctly after a user logs in to their GameCircle account. Users can only log in on a non-Amazon device as they are the only ones with the "Log in" button.

    In the GameCircle window where it says you are a guest and it has buttons below for leaderboards, achievements etc. there is an error message. It shows up in a light red box near the top of the screen: "Sorry an error occurred. Please try again later." I assume that's related somehow?

    I have also posted on the Amazon developer forums: https://forums.developer.amazon.com/forums/thread.jspa?threadID=1392&tstart=0
     
  2. TMK

    TMK

    Joined:
    Mar 29, 2010
    Posts:
    83
    Have you added your nickname as a tester using the "Add a Nickname" feature on the Amazon portal? You might have to do that first. Login to the Amazon Developer Portal, go to GameCircle, and on the list of your GameCircle apps, there should be a "Add a Nickname" option.

    Also, on your Amazon Device, you might have to go to the GameCircle settings and set your account to not be Hidden so that it will be public. For me, it said "Hidden" instead of "Guest" if I didn't do that.
     
  3. PeterAWS

    PeterAWS

    Joined:
    Nov 5, 2013
    Posts:
    1
  4. kablegames

    kablegames

    Joined:
    Nov 17, 2018
    Posts:
    1
    Yea am suffering from a issue on game circle where on the game was supercards I had a account linked to game circle and when season 5 dropped I had a local save aswell so when I tryed to login to my game circle the local save overrid my game circle account had now the local save has become my new game circle account even tho i don't want the local save as that account I was using the Samsung galaxy s8+
     
unityunity