Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question Game view scale won't go lower than 1.3x in 16/9 display mode

Discussion in 'Editor & General Support' started by Magnesium, Jul 8, 2023.

  1. Magnesium

    Magnesium

    Joined:
    Sep 14, 2014
    Posts:
    179
    Hello,

    I don't know when this started but for some reason, the display scale won't go lower than 1.3x in game view when i set it to a ratio like 16/9 and it looks terrible. If i specify a resolution instead, i can drop it down to 1x or even lower but it's not practical. Is there a fix?

    Thanks
     
  2. CodeSmile

    CodeSmile

    Joined:
    Apr 10, 2014
    Posts:
    4,961
    That scale slider's range changes dynamically with (for what I know):
    • the size of the editor window
    • the size of the game view within the editor window
    • the desktop screen resolution
    • the aspect ratio and game resolution (as you noticed)
    Try changing the size of the game view first to see how that affects the available value range of the slider.
     
  3. Magnesium

    Magnesium

    Joined:
    Sep 14, 2014
    Posts:
    179
    I thought about that but no matter the size of the game view, the available scale settings are the same.

    upload_2023-7-8_16-0-1.png
     
  4. CodeSmile

    CodeSmile

    Joined:
    Apr 10, 2014
    Posts:
    4,961
    Interestingly, when I lock it to 16:9 aspect the scale slider (at least the lower end) sticks to 1x no matter the size of the view or window.

    What your desktop resolution set to?
     
  5. Magnesium

    Magnesium

    Joined:
    Sep 14, 2014
    Posts:
    179
    My two main screen are 2560x1440. My computer is also connected to a 1920p Wacom graphic tablet and a 4k TV, both of which are currently turned on and disabled in Windows.
     
  6. CodeSmile

    CodeSmile

    Joined:
    Apr 10, 2014
    Posts:
    4,961
    Hmmm ... maybe it gets confused with the multiple monitors/resolutions. Or maybe the editor window stretches into one of the other screens just a little bit and that messes it up? Maybe also try restarting the editor.

    I made a 32:9 aspect ratio like my monitor and that still defaults to 1x no matter how I resize the editor or view.
     
  7. Magnesium

    Magnesium

    Joined:
    Sep 14, 2014
    Posts:
    179
    I don't think so, i always run the editor Unity's Window in fullscreen, so it can't be overflowing on another monitor, and i've had this screen configuration for years.
     
  8. Magnesium

    Magnesium

    Joined:
    Sep 14, 2014
    Posts:
    179
    Am i the only one having this issue? I met with my graphic designer last weekend and it was working fine on the same project.

    Edit: Got it, it was because i had "Low resolution aspect ratio" checked. Not sure if this is the expected behavior though.
     
    Last edited: Jul 21, 2023
    Jerry_Davis likes this.
  9. npatsiouras_ntua

    npatsiouras_ntua

    Joined:
    Feb 11, 2023
    Posts:
    15
    I just had this issue, but in my case the problem was Scale in the Windows 11 Display Settings, which makes sense to interfere as it's a system wide setting. It was set to 125%, which low-capped the Scale of the window to 1.3.
     
    Komodeo likes this.
  10. Bloodday

    Bloodday

    Joined:
    Sep 3, 2012
    Posts:
    1
    I had this problem, but get it corrected changing the renderer from hight dynamic range, to low dynamic range. after that I can change it to hight dinamic range and the problem didn't appear again.
     
    Last edited: Aug 22, 2023
  11. Jerry_Davis

    Jerry_Davis

    Joined:
    Jan 29, 2022
    Posts:
    5
    I met the same problem, and searching for solution, but not found yet
     
  12. Jerry_Davis

    Jerry_Davis

    Joined:
    Jan 29, 2022
    Posts:
    5
    Oh! I coincidently find the solution: close the game window , and reopen it. Hope it works for you
     
    akrocq, BarretoPEXT, uniGama and 2 others like this.
  13. julianwitte

    julianwitte

    Joined:
    Oct 3, 2012
    Posts:
    12
    I just reported a bug on this issue: "IN-59677 - UI Scaling affects Game Scale".

    In the Editor Preferences, if UI Scaling value is higher than 100%, it forces the Game view Scale to change on play.
     
  14. lichking8568

    lichking8568

    Joined:
    May 7, 2022
    Posts:
    2
    i had same problem in unity 2022.3.12f and i solved this problem like this :
    click on Aspect in Game window then UNCHECK Low Resolution Aspect Ratios.
     
  15. BarretoPEXT

    BarretoPEXT

    Joined:
    Feb 24, 2022
    Posts:
    1
    It worked for me, thanks!
     
  16. Opaweynch

    Opaweynch

    Joined:
    Jan 23, 2023
    Posts:
    31
    Worked for me too, thanks. For the record the issue appeared after I switched from a 5120x1440 monitor scaled at 100% to a 2560x1440 scaled at 125% (by "scaled" i mean windows 11 display settings).