Search Unity

  1. Calling all beginners! Join the FPS Beginners Mods Challenge until December 13.
    Dismiss Notice
  2. It's Cyber Week at the Asset Store!
    Dismiss Notice

Fullscreen mode doesn't run in 3.3

Discussion in 'Editor & General Support' started by nikemerlino, Mar 2, 2011.

  1. nikemerlino

    nikemerlino

    Joined:
    Jul 2, 2008
    Posts:
    66
    If I check fullscreen mode in the Player property the application starts with the resolution dialog.
    I have tried " Save and quit" and many other combinations but always without success.
    What is your experience? Anyway I've submitted a bug to Unity. It is big problem for me.
     
  2. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    32,168
    What bug? That's expected. Just because you use fullscreen doesn't mean you shouldn't get the resolution dialog. Those are two different things, and both of them are controlled in the player settings.

    --Eric
     
  3. nikemerlino

    nikemerlino

    Joined:
    Jul 2, 2008
    Posts:
    66
    Dear Eric,
    this my report using the Player setting:
    1) Default is Full Screen true/false
    2) Display Resolution Dialog enabled/disabled

    First app 1) true 2) disabled, result: no Display Resolution Dialog, no Full Screen, no Display Resolution Dialog with option key
    Second App 1) true 2) enabled, result: no Display Resolution Dialog, no Full Screen, yes Display Resolution Dialog with option key

    At the moment I can't run applications in Full Screen mode at startup using the Player settings

    maybe it is not a bug but this is the first time in 4 years.....
    Thanks
     
  4. nikemerlino

    nikemerlino

    Joined:
    Jul 2, 2008
    Posts:
    66
    To avoid any misunderstanding with Screen.fullscreen = true in a Script, the application runs fine at startup
     
  5. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    32,168
    OK, that's somewhat different from your first post. There is, in fact, a bug where an app reverts to non-fullscreen after the first run. I expect you have leftover prefs that are interfering here. If you delete the prefs or publish under a new name, you will see the expected behavior. I reported the non-fullscreen reverting bug a while ago but unfortunately it's still not fixed in Unity 3.3. You can always switch to fullscreen using command-F at any time, but it still makes your games seem unprofessional to have fullscreen switched off like that for no reason, and it seems like it should be trivial to fix (especially considering it didn't do this until a couple versions ago).

    --Eric
     
  6. nikemerlino

    nikemerlino

    Joined:
    Jul 2, 2008
    Posts:
    66
    The problem seems to be the unity.companyName.AppName.plist.
    This property: Screenmanager is Fullscreen mode is always setted to 0.
    If you delete this file the application runs as aspected only the first time.
    I think it is really easy to fix it.
     
  7. BasketQase

    BasketQase

    Joined:
    Sep 12, 2005
    Posts:
    97
    Actually, I find that it always toggles "Screenmanager is Fullscreen mode" when it saves. First run will be fullscreen. Quit. Second run will be windowed. Quit (without changing back to fullscreen before quitting). Third run will be in fullscreen again.

    Edit
    I take it back. It will always play in windowed as described in the earlier posts unless you change Screen.fullScreen. If you change Screen.fullScreen during the app's execution, the app will save the fullscreen state to the opposite of whatever Screen.fullScreen was last set to.
    /Edit

    This is awful if you actually allow the user to change the fullscreen settings in an options menu since whatever they set it to, the app will switch to the opposite on its next run. I just tried setting my own pref for the option, which works, but it's a little messy since the app will initially start in the opposite setting (i.e. if the user selected to play in windowed, on start up if will be fullscreen first, then windowed once it's loaded the pref and adjusted Screen.fullScreen accordingly).
     
    Last edited: Mar 29, 2011
  8. BasketQase

    BasketQase

    Joined:
    Sep 12, 2005
    Posts:
    97
    So if you don't want your user to have a windowed choice, you can simply set Screen.fullScreen = false right before exit and the app will load up in fullscreen the next time it is opened. The change to windowed mode beforehand is imperceptible.

    There's no clean way to do the opposite (start up in windowed mode by user's choice). The fade effect for the change to fullscreen still happens even if you try to sneak it in right before Application.Quit(). So you have the choice of a messy startup or a messy exit. Oddly I found the messy exit more disconcerting when comparing the two.
     
    Last edited: Mar 29, 2011