Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. We are looking for feedback on the experimental Unity Safe Mode which is aiming to help you resolve compilation errors faster during project startup.
    Dismiss Notice
  3. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

[Frustrating] Editor doesn't save my external script editor preferences.

Discussion in 'Editor & General Support' started by vexe, Apr 19, 2015.

  1. vexe

    vexe

    Joined:
    May 18, 2013
    Posts:
    644
    Hi all,

    It seems no matter what I do, Unity always resets the values I set for my custom external editor tool which is gVim upon restart. I set the editor executable to gVim.exe, and the arguments to `--remote-silent +$(Line) "$(File)"` but if I close and open Unity the settings revert back to UnityVs. Frustrating indeed since I sincerely hate VS. I've asked this before on UA but didn't get any answers. (crosslink)

    Thanks for any help.
     
    Last edited: Apr 19, 2015
  2. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    2,259
    Just a guess, but try deleting UnityVS folder from your project, maybe it's constantly tweaking that value when assembly reload happens.
     
    vexe likes this.
  3. vexe

    vexe

    Joined:
    May 18, 2013
    Posts:
    644
    @Tomas1856 Thanks for the reply. That does seem to work, deleting UnityVS folder and restarting Unity the setting persist. However; that's not a solution for me because I still use VS for debugging...
     
  4. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    2,259
    You should ask UnityVS developer regarding this behavior, maybe there is some setting for this.
     
  5. vexe

    vexe

    Joined:
    May 18, 2013
    Posts:
    644
    Sent an email to Jb, he confirmed that UnityVS does indeed override the setting but I could tell UnityVS not to do that by unchecking: Visual Studio Tools | Configurations | Open scripts with visual studio
     
unityunity