Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Framerate halved when Scene View and Game View visible (M1)

Discussion in 'macOS' started by Cato11, Jan 12, 2022.

  1. Cato11

    Cato11

    Joined:
    Jan 5, 2021
    Posts:
    203
    I appreciate that this is a commonly experienced issue and there are many threads about it, but they all seem to report different solutions and contradictory information.

    The issue :

    When I have Game View and Scene View visible in the Editor, the framerate is effectively halved which makes the game choppy. As soon as I maximise to just Game View, everything is smooth at 60 FPS. I have tried the various suggestions such as setting OpenGL above Metal, turning off Vsync, changing interaction mode etc. but none of this seems to make any difference.

    My setup is: 2021 M1 Pro running 2020.3.25f1. Two external monitors hooked up.

    Questions:
    1. Do we actually know when a fix for this is coming in 2020.3 LTS?
    2. I have seen reports that downgrading to 2020.3.18f1 fixes the issue. Can anyone confirm if this is true? I currently have a very slow internet connection so I don't fancy waiting hours to download the old version unless it actually works.

    Thanks very much
     
  2. alkannyunus

    alkannyunus

    Joined:
    Jul 6, 2020
    Posts:
    19
    No fix has been helped yet; however, 2021.2.7f is definitely recommended for your M1 as its a native version.
     
  3. Cato11

    Cato11

    Joined:
    Jan 5, 2021
    Posts:
    203
    But how can this be true when 2021 is not an LTS release? I am quite new to Unity and virtually all tutorials/guides recommend using the latest LTS release for development and production, since it is the most stable release.

    I don't mean to question your advice in a disrespectful way, I am just genuinely confused by the differing advice one sees.
     
  4. StaggartCreations

    StaggartCreations

    Joined:
    Feb 18, 2015
    Posts:
    2,211
    When you have both views open you're effectively rendering the scene twice, which affects performance seeing as double the amount of work has to be performed.

    If you're using Occlusion Culling, it is disabled by default for the scene view. Enabling it will likely remove some rendering overhead:
    upload_2022-1-12_14-18-32.png
    Disabling dynamic clipping and reducing the rendering range may cut down on overhead as well.

    If there are a lot of gizmos, disabling it can make a huge difference. Certain projects come to mind where this absolutely tanked performance.
     
    Peter77 likes this.
  5. Cato11

    Cato11

    Joined:
    Jan 5, 2021
    Posts:
    203
    Thanks very much for your recommendations StaggartCreations. I completely recognise that twice the work is being done to render the scene twice.

    My only issue is that I have been doing this for a year on an old Windows machine with half the horsepower of my new MacBook Pro, and it could render both views with no slowdown whatsoever. Also bear in mind I am dealing with a scene that only contains several primitive objects. There is literally nothing else to render.

    So I don't see why this should be particularly demanding from a performance perspective. It is clearly more of a bug type issue. I guess we can tweak settings as you suggest but it doesn't really get to the heart of the problem does it? If there was a proven 2020.3 LTS version that is unaffected by this bug then I would prefer just to switch back to avoid the problem altogether.
     
  6. sameng

    sameng

    Joined:
    Oct 1, 2014
    Posts:
    184
    It is not proven that 2020.3 LTS fixes this bug. I've tried them all.

    Unfortunately I suffer from the same problem. There is no real solution. Other forum users here are providing great suggestions, but every "solution" I've tried merely mitigates the issue by reducing performance requirements. Such as reducing gizmos or reducing rendering range.

    The current updated macOS versions of Unity (2020.3 LTS, 2021.2 TECH) both have atrocious editor performance.

    I have both a top-spec 2019 i9 8core 16" 5500 ($4100), and a M1 Max 10core 16" 32coregpu ($4000). Both barely struggle to keep up with my lightweight project, barely hitting 45FPS at 1600x900, with only the game view open. It fluctuates wildly, spiking between 50FPS and 4FPS.

    I lock my game to 30FPS in the editor just to make it usable, by setting Application.targetframerate. It's good enough for me to work.

    When I build my game on macOS, the built game runs really well at >100FPS on the mac.

    For reference, a 2017 Razer Blade 1070m 4core i7 ($1900) runs my project flawlessly at literally, above 120 FPS in the editor at 2560x1440, with both game view and scene view open.

    Say what you will about apple's total ripoff pricing model. I agree, I've spent way too much money on apple products. I know it's a hugely controversial company. Someone will inevitably say it's because apple hardware is total crap.

    But when I dual-boot my 2019 i9 16" into Windows and the same project has zero performance issues... something's rotten in unity macOS.

    Sadly I have a fatal flaw of wanting to use macOS.
     
    Last edited: Jan 12, 2022
  7. Cato11

    Cato11

    Joined:
    Jan 5, 2021
    Posts:
    203
    Thanks for your input Sameng. So I just noticed something interesting:

    The lag issue only occurs when the Editor window is on an external monitor. When the Editor is on the MacBook's own display, both views are buttery smooth. But as soon as I drag the window onto an external display (60Hz) it halves the framerate. Weird! I wonder if there is indeed a setting to overcome this.


    UPDATE: For the record I did try downgrading to 2020.3.18f1 and it made no difference.
     
    Last edited: Jan 12, 2022
  8. Cato11

    Cato11

    Joined:
    Jan 5, 2021
    Posts:
    203
    Also to make things stranger, if I pop out Game View into a separate Window and have that on a different monitor to Scene View, both are smoother without the framerate drops! Thankfully I have two external displays so I can re-arrange my workflow to do this. So at least there is a usable fix until Unity patches it.

    I wonder what the reason for this behaviour is.
     
    Last edited: Jan 12, 2022
  9. DavidRodMad

    DavidRodMad

    Joined:
    Jan 26, 2015
    Posts:
    13
    This is happening to me as well in 2022.2.1f1 on windows :( I have barely anything at all on my scene, just like 5 UI elements, but it tanks from 300fps to 15 is scene view is open alongside game view...
     
  10. Sarai

    Sarai

    Joined:
    Jul 20, 2014
    Posts:
    30
    Also experiencing this issue on Windows 11 when Scene window is open simultaneously with Game window.

    I noticed that the when both windows are open, the the utilization is high on "Copy". Whereas when only one of them opened, the utilization is high on 3D

    upload_2023-6-17_20-14-46.png

    upload_2023-6-17_20-16-9.png
     
  11. theshizon

    theshizon

    Joined:
    May 4, 2015
    Posts:
    8
    Hi all! This was happening to me, it was super annoying! I found a fix that worked for me. With DX11, open your NVIDIA CONTROL PANEL go to 3D settings -> Manage 3D settings -> Max Frame Rate - set this to "off" (mine was set to 30FPS). I get over 300 FPS with my scene and game view open and running now! This was with a 3080 and a Ryzen system with 64 GB of RAM so I had no reason to be running so slow. Not sure why the nvidia settings were set at 30 FPS. Cheers!
     
  12. theshizon

    theshizon

    Joined:
    May 4, 2015
    Posts:
    8
    Check your NVIDIA Control Panel -. Manage 3D settings -> set "max frame rate" to "0ff". Mine was set to 30 and I only got 15 FPS with the scene and game view open. Using DX11 on Windows 10
     
  13. theshizon

    theshizon

    Joined:
    May 4, 2015
    Posts:
    8
    Check your NVIDIA Control Panel -. Manage 3D settings -> set "max frame rate" to "0ff". Mine was set to 30 and I only got 15 FPS with the scene and game view open. Using DX11 on Windows 10
     
  14. theshizon

    theshizon

    Joined:
    May 4, 2015
    Posts:
    8
    Check your NVIDIA Control Panel -. Manage 3D settings -> set "max frame rate" to "0ff". Mine was set to 30 and I only got 15 FPS with the scene and game view open. Using DX11 on Windows 10
     
  15. Sarai

    Sarai

    Joined:
    Jul 20, 2014
    Posts:
    30
    AMD user crying
     
  16. Relecto

    Relecto

    Joined:
    May 8, 2021
    Posts:
    9
    I recently had this issue as well on Windows, but my NVIDIA Control Panel -> Manage 3D settings-> max frame rate is already "off".

    What I found is that when you open profiler and turn on "Deep profile" the issue goes away.
    Can anybody try this and see if it helps?

    Although that's definitely not a fix, but it may give us an insight about the underlying problem
     
  17. windfuryEVO

    windfuryEVO

    Joined:
    Jul 18, 2012
    Posts:
    1
    Tried your "Deep profile" method and it didn't work for me. I've followed all other suggestions in this thread as well and nothing has worked.