Search Unity

Bug FPS cut in half when building to android

Discussion in 'VR' started by ShinsuiOkatami, May 17, 2023.

  1. ShinsuiOkatami

    ShinsuiOkatami

    Joined:
    Sep 21, 2022
    Posts:
    1
    I've been experiencing a bug that cuts my fps in half when building for android.

    Background info: When running the game in the editor, it runs at 72 fps, but experiences frequent frame drops at random intervals. When building and playing on android, it runs at 36 fps with little to no fps changes.

    I'm using URP, the oculus integration, my unity version is 2022.1.16f1, I've optimized my game with baked lighting, static batching, and set all graphics to the lowest levels, even turned off anti aliasing, and I am using Photon Pun 2 for multiplayer networking.

    Any help would be greatly appreciated!
     
  2. Deleted User

    Deleted User

    Guest

    Typically on mobile platforms the default frame rate is 30FPS. Note that setting targetFrameRate does not guarantee that frame rate. There can be fluctuations due to platform specifics, or the game might not achieve the frame rate because the application is using too much processing power. You can set this value at the start of a C# script.
    Code (CSharp):
    1. using UnityEngine;
    2.  
    3. public class Example
    4. {
    5.     void Start()
    6.     {
    7.         // Make the game run as fast as possible
    8.         Application.targetFrameRate = 120;
    9.     }
    10. }
     
  3. Deleted User

    Deleted User

    Guest

    You can also try this:
     
  4. DevDunk

    DevDunk

    Joined:
    Feb 13, 2020
    Posts:
    5,050
    The 36 fps is because of vsync. Your performance is too bad to hit 72fps.

    Check the profiler to see where performance goes maybe
     
    Ryiah likes this.