Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Resolved fps bug in recorder with include audio

Discussion in 'Audio & Video' started by iiizumi, May 16, 2022.

  1. iiizumi

    iiizumi

    Joined:
    Sep 18, 2019
    Posts:
    4
    Hello.
    When recording with "include audio" checked mp4, fps is set to 1 after 2 seconds.

    The problem occurred in UnityEditor2020.3.6f1,UnityRecorder2.5.7, if when this problem occurred, it also happened in other versions.
    and this problem also occurs in empty projects(i tested unityeditor 2021.3.2f1,recorder 3.0.3)'

    I recorded it on my audio recorder and it played back at 2x speed. but fps did not drop.
    I don't know what the problem is since there is no error log,
    thanks
     

    Attached Files:

  2. vladala

    vladala

    Unity Technologies

    Joined:
    Mar 3, 2017
    Posts:
    189
    Hey,

    To make sure I understood: you are saying that your game's framerate drops to a very low number when you enable mp4 recording with "capture audio" ?

    Do you notice the same issues recording mp4 without the audio capturing ?
    Tried with ProRes encoding ?
    If possible, could you enable the profiler and show me where is the time being spent while the framerate is this low ?
     
  3. iiizumi

    iiizumi

    Joined:
    Sep 18, 2019
    Posts:
    4
    Thanks for the reply.

    ・Without include audio, the recording is working fine.
    ・ProRes encoding can record but the sound will be twice as fast.
     

    Attached Files:

  4. vladala

    vladala

    Unity Technologies

    Joined:
    Mar 3, 2017
    Posts:
    189
    Hey,

    Unfortunately I am not sure I can help you much: All that time is taken by the OS to encode your h264.
    Only suggestion I could have is to switch to VP8 (WebM) or lower even more the h264 params ( I expect you will get even more compression artefacts )
     
  5. iiizumi

    iiizumi

    Joined:
    Sep 18, 2019
    Posts:
    4
    Resolved
    I changed the audio driver and it now works as before.
    (I used windows default audio driver and now i install realtek driver)
     
    vladala likes this.