Search Unity

Four blank errors in each new project

Discussion in 'Editor & General Support' started by Annundur, Dec 18, 2018.

  1. Linzilla

    Linzilla

    Joined:
    May 31, 2013
    Posts:
    5
    hello,
    if you can not update your win7 then you need
    its https://www.microsoft.com/de-DE/download/details.aspx?id=53335
    and https://www.microsoft.com/en-us/download/details.aspx?id=46817
    if you have your update service disabled it wont work, you can unplug your internet activate the service update and then disable it again. one of the two first; also sp1. i think it was the id=46817 then you can run the other; if it says can not update some KB update is missing ...
    hope this can help you :)
     
  2. MuzzleStudio

    MuzzleStudio

    Joined:
    Feb 22, 2017
    Posts:
    2
    I am facing exactly same problem of 4 blank spaces in Unity 2018.3.7 and 2018.3.9..
     
  3. grobonom

    grobonom

    Joined:
    Jun 23, 2018
    Posts:
    116
    HeathCliff1020 likes this.
  4. ranjini

    ranjini

    Joined:
    May 21, 2019
    Posts:
    1
    same problem, i am searching for solution to fix these errors as soon as possible!!!!!
     
  5. grobonom

    grobonom

    Joined:
    Jun 23, 2018
    Posts:
    116
    @ranjini did you try to install the small windows update ?
    it worked perfectly for me
     
  6. mehdipol

    mehdipol

    Joined:
    May 31, 2019
    Posts:
    1
    I also was getting the 4 blank errors in Unity
    I update my Win7 with windows update

    the error is gone
     
  7. Moonstorm

    Moonstorm

    Joined:
    Jul 26, 2012
    Posts:
    22
    Doesn't work for me, and I have Windows 10 with all installed updates
     
    Joe-Censored likes this.
  8. Sparkpin

    Sparkpin

    Joined:
    Mar 28, 2018
    Posts:
    1
    None of the posted solutions worked for me. I've tried switching to using .NET 3.5, but this only produced errors from TextMesh Pro (which wasn't even in the project, this was tested in an entirely new project) stating that certain features (such as `out variable declaration') could not be used because they were not part of C# 4.0 (?!??!). I'm on Xubuntu 19.04 running Unity 2019.1.6f1. I've also tried Unity 2019.1.0f2, which has worked for me before, but unfortunately it appears this version is also not working. Here are the steps to reproduce:

    1. Create a new project.

    This is a bit of a roadblock for me when trying to make games.

    EDIT: Apparently, Unity relies on libssl 1.0.0, an old version which is no longer available in Ubuntu 19.04 and upwards. More info and the correct package are available from this post.
     
    Last edited: Jun 14, 2019
  9. MaxKMadiath

    MaxKMadiath

    Joined:
    Dec 10, 2016
    Posts:
    10
    I also got the same error and i just uninstalled unity (2019.1.6f1) and deleted all the folder related to unity in the appdata. i.e,local, locallow and roaming. if you want to keep package that you have download then dont delete unity\Asset Store-5.x folder rest everything you have to delete and install the unity .It work for me used net 4
     
  10. MalekMC

    MalekMC

    Joined:
    Nov 25, 2016
    Posts:
    1
  11. wood333

    wood333

    Joined:
    May 9, 2015
    Posts:
    632
    I had this problem with Unity 2018 3.6.

    I solved it by changing the project setting of scripting runtime version to .NET 3.5 Equivalent (Deprecated).

    I use win 7, if that makes any difference.
     
  12. mysticxa

    mysticxa

    Joined:
    Mar 6, 2019
    Posts:
    1
    I am using the .Net 3.5 because .Net 4.0 is throwing errors for me. Meanwhile, my friend can use .Net 4.0 without any errors. So we collabed on a project and he ahs to switched to .Net 3.5 because of my problem. Now, when he is trying to to use shader and all, Unity is throwing errors. And now when he switched to .Net 4.0 all errors were now.
    Any suggestion?
    I can't use 4.0 and he can't use shaders and all without errors in 3.5.
     

    Attached Files:

  13. didous

    didous

    Joined:
    Jul 25, 2019
    Posts:
    1
    I had a problem about the 13,37 I don't know what i have to do
     
  14. meuklight

    meuklight

    Joined:
    Feb 2, 2016
    Posts:
    6
  15. junestone

    junestone

    Joined:
    May 30, 2017
    Posts:
    42
    Would you please view this issue? https://forum.unity.com/threads/help-with-aot-compilation-with-monopinvokecallback.717917/ Get stuck on that, any idea would be appreciated.
     
  16. whywhywhy323

    whywhywhy323

    Joined:
    Jul 30, 2019
    Posts:
    1
    I was having this issue of four blank errors with version 2019.1.12f1 on Linux. In my case, changing to .net 3.5 didn't help but installing this version of libssl fixed the problem for me, thank you.

    In Fedora this is contained in the package compat-openssl10, which can be installed with
    sudo dnf install compat-openssl10
     
  17. Mohammad75

    Mohammad75

    Joined:
    Jul 31, 2019
    Posts:
    1
  18. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    5,467
  19. wood333

    wood333

    Joined:
    May 9, 2015
    Posts:
    632
    Is Unity going to fix this win 7 .NET 4.x bug or just drop all support of win 7?
     
  20. CyRaid

    CyRaid

    Joined:
    Mar 31, 2015
    Posts:
    80
    I have Windows 10. It seems none of these apply to me. I run Unity 2019.2.0f1. I get 4 blank errors.
    This started somewhere after I upgraded to 2019.2 (from 2019.1), and using Google Play Games Services.. I'm guessing it has to do with an outdated API script somewhere, as it also is accompanied by a 'it will compile when the obselete scripts have been fixed' or something. But it's not telling me *which* scripts need to be updated? It also pops up the "I made a backup" dialog on every start. (that was apparently caused by Google Play Games Services)

    Edit: Also, it's fine before I build for the first time, then I build the second time, then the 4 blank errors pop up.
    Edit Edit: I managed to find a workaround.. So when it does this, I locate VBCSCompiler.exe in task manager, end the task, then reimport a directory that contains scripts. Usually does the trick for me. Just very annoying as this happens every 1-2 builds (even patch and run)..

    Also, don't forget to terminate the java executable as well, then reimport something small to trigger a recompile. Some of these things can be pinned to running out of memory.
     
    Last edited: Aug 29, 2019
  21. projoel

    projoel

    Joined:
    Aug 24, 2019
    Posts:
    1
    I also have the same problem
     
  22. CyRaid

    CyRaid

    Joined:
    Mar 31, 2015
    Posts:
    80
    Read my post ^ if you can. Try ending VBCSCompiler.exe and the java (openjdk) executable from task manager, then reimport something small that triggers a recompile.
     
  23. mugen-sosa

    mugen-sosa

    Joined:
    Mar 12, 2015
    Posts:
    4
    this worked for me
    "
    Loading error for hostfxr.dll on Windows
    If the Console reports that the hostfxr.dll library was found, but Unity failed to load it from C:\<path_to_app>\hostfxr.dll, you can fix this error on Windows 7 or Windows Server 2008 R2 by installing both KB2999226 and KB2533623 patches.

    ."
    check it here https://docs.unity3d.com/Manual/upm-errors.html