Search Unity

Forcing OpenGL 2 on all builds

Discussion in 'Windows' started by StealThePixels, Mar 31, 2016.

  1. StealThePixels

    StealThePixels

    Joined:
    Apr 2, 2015
    Posts:
    68
    I am using Unity 5.1.1 on Windows and i am trying to make a build , targeting another platform (OSX) but forcing the graphics API to OpenGL 2 because the game uses a plugin which requires it to properly work on Mac.

    But in the attached screenshot you can read "Graphics APIs for Windows" in the Rendering settings , despite i am targeting Mac.
    And of course, the game on Mac has issues with the plugin in question ( CoherentUI ) which is working well on Windows.

    So i am wondering if my OpenGL setting were correct. What am i missing in order to force OpenGL2 ?

    Thanks
     

    Attached Files:

  2. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    7,036
    Hi,

    in Unity 5.1.1, OpenGL2 is the only graphics API available for OS X (and linux) standalone player, so there's no point in allowing its selection. It only mattered on Windows, since it supported D3D9, D3D11 and OpenGL2.

    Now, if you open this in 5.3, it will be different, as OS X now supports OpenGL2 and OpenGLCore.
     
  3. Voronoi

    Voronoi

    Joined:
    Jul 2, 2012
    Posts:
    296
    Is it even possible to build using OpenGL2 on a Mac Standalone? I've set my API preferences to try to build OpenGL and the resulting app crashes. I can build using Metal and OpenGLCore...

    This is tested by creating a new Empty project and just adding a Cube with 5.4 beta 13.
     
    Last edited: Apr 8, 2016
  4. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    7,036
    It should work. Please submit a bug report with details of your machine: OS X version, GPU, and the project attached.
     
unityunity