Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Force No Motion option for Mesh Renderers does not work as intended

Discussion in 'General Graphics' started by Grumpy-Dot, Jun 22, 2020.

  1. Grumpy-Dot


    Feb 29, 2016
    I am not sure if this is intended or just some confusion on my part.
    I've set up a simple scene with Unity 2019.4 and Post Processing v2.3.0 with a Camera, a Directional Light and a Cube with Default-Material.
    The Camera has a Post-process Layer component and a Post-process Volume component with only the Motion Blur effect.
    When the Cube mesh renderer component has the option Motion Vectors = Force No Motion, the Frame Debug actually shows an extra SetPass call to the MotionVector.Render -> MotionVector.RenderJob -> Draw Mesh Cube.

    When setting either Motion Vectors = Camera Motion Only or Motion Vectors = Per Object Motion, and the object does not move, the extra SetPass on the MotionVector.Render disappears.

    Is this a bug or just bad naming? How can one disable Motion Vectors for specific meshes entirely?