Search Unity

  1. Unity 2019.1 is now released.
    Dismiss Notice

For people targeting cardboard on Android please update your Google VR SDK to 1.12 or later.

Discussion in 'Daydream' started by joejo, Mar 8, 2018.

Thread Status:
Not open for further replies.
  1. joejo

    joejo

    Unity Technologies

    Joined:
    May 26, 2016
    Posts:
    540
    Unity recently updated their built in Google VR Android NDK version to 1.100. Unfortunately we introduced an incompatibility in the Java layer that affects Cardboard applications on non-Daydream devices. We recommend that users manually update the Google VR SDK for Unity to 1.120 or later as that will install an updated library that should work. We'll post to this thread when updates should arrive in shipping versions. Links to instructions and download here

    If you are using these versions or later you are affected:

    2018.1.0 b3 - Fixed in 2018.1.0 b12
    2017.3.1 p1 - Fixed in LTS 2017.4.1 f1
    2017.2.1 p3 - Fixed in 2017.2.2 p3
    2017.1.3 p1 - Fixed in 2017.1.3 p3
    5.6.5 p1 - Fixed in 5.6.5 p4
     
    Last edited: Mar 15, 2018
Thread Status:
Not open for further replies.