Well, these names are more or less descriptive, matching the inspector names. DF corresponds to primitives, that one was not descriptive. I don't like either having such big amount of variants, but that was the only way to make the plugin flexible, with many options. I wish there was a better way. But the idea is simple, if you are not going to activate volumetric shadows, comment this line: #pragma multi_compile _ VOLUME_SHADOWS If you don't need lights, comment this out #pragma multi_compile _ ATTEN_METHOD_1 ATTEN_METHOD_2 ATTEN_METHOD_3 And so on. Hopefully you will only need to remove a few. Sorry for the inconveniences. I understand and share the nuisance.