Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Audio FMOD failed to initialize

Discussion in 'Audio & Video' started by LawrenceDev, Dec 24, 2018.

  1. LawrenceDev

    LawrenceDev

    Joined:
    Aug 20, 2015
    Posts:
    27
    Hello everyone, my audio doesn't work and I get these errors in the command line:
    FMOD failed to initialize. This may be because your sound card is configured to give applications exclusive access, thus preventing Unity from using this device. You can change this in Control Panel > Audio Devices and Sound Themes > Playback Device > Properties > Options ... : "Soundcard does not support the minimum features needed for this soundsystem (16bit stereo output). " (59)

    and

    Forced to initialize FMOD to to the device driver's system output rate 48000, this may impact performance and/or give inconsistent experiences compared to selected sample rate 48000

    These are my audio settings (excuse me for the dutch text):
     
  2. LawrenceDev

    LawrenceDev

    Joined:
    Aug 20, 2015
    Posts:
    27
  3. Lurking-Ninja

    Lurking-Ninja

    Joined:
    Jan 20, 2015
    Posts:
    4,488
    May I ask you to stop spamming the forum? If someone has anything to add to the situation, will write you an answer. In the mean time try the FMod support, they may have anything to add. This isn't a Unity problem anyway.
     
  4. LawrenceDev

    LawrenceDev

    Joined:
    Aug 20, 2015
    Posts:
    27
    I'm not really spamming, but OK.
     
  5. LawrenceDev

    LawrenceDev

    Joined:
    Aug 20, 2015
    Posts:
    27
    For anyone wondering, I fixed this problem by disabling all NAHIMIC processes in task manager.
     
    The_infern0, prdas31 and BeatrizAbreu like this.
  6. nlv22

    nlv22

    Joined:
    Dec 20, 2016
    Posts:
    19
    This is from a while ago, but it still helps. Thanks Laurens! I had a similar problem but with Aliensware's middleman software which I disabled.
     
  7. LawrenceDev

    LawrenceDev

    Joined:
    Aug 20, 2015
    Posts:
    27
    No problem ;)
     
  8. rkatos

    rkatos

    Joined:
    Sep 13, 2013
    Posts:
    1
    Thanks, I did the same for the Nahimic and it worked for me!
     
  9. yoinkmyyeet

    yoinkmyyeet

    Joined:
    Jun 24, 2019
    Posts:
    1
    I love you so much it fixed rust for me HELL YEAH IT WORKS!!!!
     
  10. Leshaun

    Leshaun

    Joined:
    Jun 24, 2019
    Posts:
    1
    Oh THANK YOU! This was screwing up all kinds of programs I was running, awesome!
     
  11. takoss123

    takoss123

    Joined:
    Jul 7, 2019
    Posts:
    1
    I have the exact same problem however your solution doesn't work because I don't have any Nahimic processes at all. I am wondering if there is any other way to fix this. Thanks in advance.
     
  12. unity_XN5Bzzw0l9_csA

    unity_XN5Bzzw0l9_csA

    Joined:
    Jul 21, 2019
    Posts:
    1
    hello i have the same problem but i don t know how to fix it im on alienware
     
  13. LawrenceDev

    LawrenceDev

    Joined:
    Aug 20, 2015
    Posts:
    27
    Go to task manager > processes
    Then close the Alienware Audio software (if that exists)
     
  14. ferretnt

    ferretnt

    Joined:
    Apr 10, 2012
    Posts:
    309
    I've been experiencing the same thing on my primary windows dev machine (Alienware 15 R3) since updating Alienware Drivers earlier this year (which I think I did because Beat Saber stopped working at some point because SteamVR is a shonky pile of piles of stuff on top of piles of stuff) and none my various googlings for "Alienware Unity FMOD blah blah" helped.

    Although many posts point fingers at uninstalling Nahimic, that's not helpful if you haven't installed it (and in fact, I keep my dev laptop as clean as possible.)

    The correct solution if you're running a reference-ish AW build is to disable AlienWare sound Centre completely. There's no UI to do this because it's built into the driver installer and launched on startup, so you'll have to use autoruns for it. Some screenshots and links below. (Side note: Autoruns is generally awesome for keeping your PC from having assorted crap running on startup. I'd forgotten about it.)

    https://www.reddit.com/r/Alienware/comments/6hz6sl/alienware_sound_center_bug/dj3q3h3/

    You may also have to disable "Exclusive Mode" on the sound card (as the error message suggests.) I'd done that weeks ago.

    You can PROBABLY also fix it by downloading the "official" (and I use that word in the loosest possible terms...) Realtek reference drivers, but I couldn't even figure out what exact link to get them from. This may or may not be correct, but if you only speak English you'll need Google Translate to try to do better...

    https://www.realtek.com/en/componen...-codecs-high-definition-audio-codecs-software
     
  15. Aldir_21

    Aldir_21

    Joined:
    Apr 11, 2018
    Posts:
    1
    alienware is not in my task manager, I've tried updating the sound driver and updating the unity to the latest version but still can't fix it, is there another solution?
     
  16. ferretnt

    ferretnt

    Joined:
    Apr 10, 2012
    Posts:
    309
    Yes, in the answer I posted above.
     
  17. The_infern0

    The_infern0

    Joined:
    Sep 10, 2019
    Posts:
    1
    old thread but this fixed SO MANY problems I was having, we need to spread this news from across the rooftops!
     
  18. Sharpthorne

    Sharpthorne

    Joined:
    Oct 3, 2019
    Posts:
    1
    Copied this from another forum. It fixed my issue:
    This is possibly an issue with the AudioSrv service in Windows. Go to the TaskManager. Go to the Services tab. Find 'AudioSrv' in the list, right click and Restart it. Then restart Unity. Should fix it.
     
  19. Kademlia85

    Kademlia85

    Joined:
    May 4, 2018
    Posts:
    1
    i did two things and i don't know which one exactly helped with this as i had multiple warnings on launch.

    option 1) is what's listed above, restarting 'AudioSrv' in TaskManager

    the second one is a problem i've always experienced with unity or games done in unity; which is a problem with windows security.

    right click unity launcher and select properties
    go to compatibility, and click change settings for all users
    in the bottom there is:
    "Run this program as an administrator"

    with both of those done, i now have no errors running unity. this same thing works on all the games that i've ever had sound problems with and are made with unity.

    basically that's a generic fix for audio problems on anything, i first experienced this with windows 10 coming out, and that's always been my regular fix.

    about 80% of the time this fixes it, the problems with "game running but no audio" problem. the last 20% is that the game has a launcher which runs the actual game which then doesn't have the right use audio devices, which you fix the same way but you have to go to the game folder and do this on the actual AwesomeGame.exe.