Search Unity

Flickering shadows in HDRP

Discussion in 'Graphics Experimental Previews' started by SunnySunshine, Oct 27, 2018.

  1. SunnySunshine

    SunnySunshine

    Joined:
    May 18, 2009
    Posts:
    676
    I checked out HDRP several months ago and remember noticing that realtime shadows behaved oddly. I didn't think too much about it at the time, as HDRP is still in beta, and perhaps I wasn't configuring the options optimally. However, now when I'm checking out the FPS sample project (great job on that btw), I notice the shadows still behave strangely. No matter how much I try to configure the HD Shadow settings in the volume component, there will always be very noticeable flickering at the edge of the shadows. Here's a video:

    https://gyazo.com/781fe6ad9e297447c9651a1810e5f136

    This is not a problem in the default rendering pipeline:

    https://gyazo.com/583084a09cf1d8aea8316612dd14be24

    Is this a known issue that will be fixed, or what's going on?
     
  2. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    7,691
    I would like to know about this too, i get flicker a lot in volume lighting in Unity 2019.2 and latest HDRP
     
  3. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    25,618
    Please note down HDRP version numbers exactly as it really matters.

    This is not flickering, it's simply the shadows are set to lower resolution. I tweaked the settings for my game and all that went away.

    But they don't if I use default settings.

    You need to start digging into HDRP volume and engine settings files and tweak it to your game's requirements. As such I *really* think there is no problem here other than a failure to touch any options.
     
  4. SunnySunshine

    SunnySunshine

    Joined:
    May 18, 2009
    Posts:
    676
    When I tried tweaking settings before, while the flickering could be reduced, it could not be entirely eliminated. Things might have changed since then, so maybe it's better now, and atm I'm not investigating HDRP. But just out of curiosity - what settings exactly did you change? I remember playing around with shadow cascade biases and resolutions, but to no avail.
     
  5. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    7,691
    I played with all possible setting that not require coding and i still get some flickering in image effects that query depth, it is like some internal problem in the engine.
     
  6. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    7,691
    HDRP version is 5.2.3, used in Unity 2019.2.0a9
     
  7. rizu

    rizu

    Joined:
    Oct 8, 2013
    Posts:
    1,177
    I'm surprised this even works, not only 5.2.3 is super early version of 5.x HDRP, it's not very stable in general. You are using all possible unreleased things with a mix that's not even officially supported. Use 6.7.1 or later for 2019.2 + your 2019.2 is really old as well, we are currently at 2019.2b7.

    In general, if you want more stable experience, stick to the released Unity versions, right now this means latest 2019.1 and couple it with 5.16.1 HDRP.
     
    nasos_333 likes this.
  8. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    7,691
    I used this one because was supposed to be the way to go to make image effects for the new pipelines, there was a tutorial about it as well.

    Of course all that is changing now i guess. I hope we get a similar tutorial on how to convert our effects to the HDRP image effects soon.
     
  9. MikeChr

    MikeChr

    Joined:
    Feb 2, 2018
    Posts:
    25
    I can eliminate the flickering when I disable the Static Lighting Sky component from my Scene Settings profile. Using 2019.1.9f1 and hdrp 5.16.1.
     
  10. manutoo

    manutoo

    Joined:
    Jul 13, 2010
    Posts:
    322
    I also have strong shadow flickering, especially on the 2nd cascade, with Unity 2019.1.12f1 + HDRP 5.16.1 + Directional light + any shadow filtering in HDRenderPipelineAsset -> Lighting -> Shadow -> Filtering Qualities.

    However, it only happens when I change the camera FOV (which can be all the time in my game, depending on the camera mode chosen by the user).

    It was workly flawlessly with the Built-in pipeline. :(

    EDIT:
    raising the Directional Light's Shadow Map Resolution from 512 to 2048 fixed the issue, and in bonus now the shadows look as good as in the Built-in pipeline..! :p
     
    Last edited: Aug 11, 2019