Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We’re making changes to the Unity Runtime Fee pricing policy that we announced on September 12th. Access our latest thread for more information!
    Dismiss Notice
  3. Dismiss Notice

Bug Firebase causing crash (can't build or play) - FB v6.15.2

Discussion in 'Editor & General Support' started by ddooms, Sep 12, 2020.

  1. ddooms


    Jun 10, 2015
    I recently built a computer, and now I'm trying to open my projects on the new computer.
    Currently, I am experiencing crashes every time I hit play in the editor. I cannot build, either.

    I have provided the crash dumps and all. This seems to be an issue with the Firebase plugin, as I am getting an access error from Unity.
    I used unity collab first to try and move the project over, and then found the crashes - I figured collab may have screwed something up so then I transferred the whole folder using an external drive.

    Since it's still crashing, I went to the crash dumps and found that Firebase (version 6.15.2) seems to be causing the crash with an exception code of "0xC0000005":
    "The thread tried to read from or write to a virtual address for which it does not have the appropriate access."
    I tried opening unity with administrator privileges but it did not change anything, so I imagine Firebase is doing something behind the scenes.

    It's worth noting that before I found the stack trace, I was finding errors in the unity console about a script that contains firebase functions, but I couldn't figure out which function it was. I can post that if the dumps aren't enough for people to help me out!
    I would appreciate any help on this, as it goes above my head.

    Stack trace:
    Code (log):
    2. ========== OUTPUTTING STACK TRACE ==================
    4. 0x00007FFF1C486504 (FirebaseCppApp-6_15_2) SWIGRegisterStringCallback_StorageInternal
    5. 0x00007FFF1C41F344 (FirebaseCppApp-6_15_2) SWIGRegisterStringCallback_StorageInternal
    6. 0x00007FFF1C4D98FD (FirebaseCppApp-6_15_2) SWIGRegisterStringCallback_StorageInternal
    7. 0x00007FFF1C48B843 (FirebaseCppApp-6_15_2) SWIGRegisterStringCallback_StorageInternal
    8. 0x00007FFF1C48C4EC (FirebaseCppApp-6_15_2) SWIGRegisterStringCallback_StorageInternal
    9. 0x00007FFF1C485107 (FirebaseCppApp-6_15_2) SWIGRegisterStringCallback_StorageInternal
    10. 0x00007FFF1C48529A (FirebaseCppApp-6_15_2) SWIGRegisterStringCallback_StorageInternal
    11. 0x00007FFF1C48BEAC (FirebaseCppApp-6_15_2) SWIGRegisterStringCallback_StorageInternal
    12. 0x00007FFF1C2442A8 (FirebaseCppApp-6_15_2) SWIGRegisterStringCallback_StorageInternal
    13. 0x00007FFF1C6609ED (FirebaseCppApp-6_15_2) SWIGRegisterStringCallback_StorageInternal
    14. 0x00007FFFA5CE6FD4 (KERNEL32) BaseThreadInitThunk
    15. 0x00007FFFA787CEC1 (ntdll) RtlUserThreadStart
    17. ========== END OF STACKTRACE ===========

    Attached Files:

  2. gputhread


    Dec 7, 2018
    same here,no fix!