Search Unity

  1. Unity 2019.4 has been released.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  3. Ever participated in one our Game Jams? Want pointers on your project? Our Evangelists will be available on Friday to give feedback. Come share your games with us!
    Dismiss Notice

FindKernal Fails

Discussion in 'Linux Editor' started by thecraftycodingfangirl, Sep 17, 2017.

  1. thecraftycodingfangirl

    thecraftycodingfangirl

    Joined:
    Sep 17, 2017
    Posts:
    1
    I imported a game project into a fresh install of the 2017.2.0b11 Linux editor on my Ubuntu 16.04 system. Said game project had been built using the Windows editor on Win10.

    The project eventually loaded but I was greeted with the series of error messages that follows:
    I'm quite new to working with Unity and as I know the Linux version is not formally supported at the moment I'm hesitant to file a bug report about the issue. I'm going to be doing level design to help my husband with this game project he's been developing. If anyone can point me in the right direction to resolve these issues, it would be most appreciated.
     
  2. Tak

    Tak

    Unity Technologies

    Joined:
    Mar 8, 2010
    Posts:
    974
    It looks like this is an issue with a third-party package (Lighting Box) not being able to find a particular kernel in one of its compute shaders.
    I wasn't able to duplicate this behavior with their test scenes, so it may be related to either your project or your machine - filing a bug report would give us more information to track down the issue.
     
  3. zero_null

    zero_null

    Joined:
    Mar 11, 2014
    Posts:
    159
    Hello.
    I am having the same issue on Unity 2018.1.3 ! I am using the post processing stack 2


    UnityException: FindKernel failed
    UnityEngine.Rendering.PostProcessing.ScreenSpaceReflectionsRenderer.Render (UnityEngine.Rendering.PostProcessing.PostProcessRenderContext context) (at C:/Users/GS/AppData/Local/Unity/cache/packages/packages.unity.com/com.unity.postprocessing@2.0.7-preview/PostProcessing/Runtime/Effects/ScreenSpaceReflections.cs:210)
    UnityEngine.Rendering.PostProcessing.PostProcessLayer.BuildCommandBuffers () (at C:/Users/GS/AppData/Local/Unity/cache/packages/packages.unity.com/com.unity.postprocessing@2.0.7-preview/PostProcessing/Runtime/PostProcessLayer.cs:400)
    UnityEngine.Rendering.PostProcessing.PostProcessLayer.OnPreCull () (at C:/Users/GS/AppData/Local/Unity/cache/packages/packages.unity.com/com.unity.postprocessing@2.0.7-preview/PostProcessing/Runtime/PostProcessLayer.cs:294)
    UnityEngine.GUIUtility:processEvent(Int32, IntPtr)
     
  4. cameron990

    cameron990

    Joined:
    May 5, 2015
    Posts:
    6
    I had this happen now HDRP is broken on my machine. I un-installed Unity and even in a new project, I get this error and no rendering of any objects. I understand its still in preview so I can't be to upset but I hope it's fixed. My project looked great in HDRP.
     
  5. dbdenny

    dbdenny

    Joined:
    Mar 13, 2020
    Posts:
    2
    Come up with the same error. And I fixed it by removing the Library directory and reimport the project. I guess the root cause is the remove/reinstall packages operations mis-update caches in the Library directory, and because this Kernel is part of shader, only removing the shader related caches should work as well (I guess), reimporting the whole project is too cost...

    BTW, my unity version is 2018.4.2
     
unityunity