Search Unity

  1. Unity 2019.1 is now released.
    Dismiss Notice

[FEEDBACK] - Can't download assets for versions that LTS Support is Given

Discussion in 'Assets and Asset Store' started by GermiyanBey, Mar 14, 2019.

  1. GermiyanBey

    GermiyanBey

    Joined:
    Aug 18, 2017
    Posts:
    13
    As Feedback Website is closed (with all the inquiries & feedbacks we posted), I couldn't find anywhere to post this and this is directly related to AssetStore topic.

    I am on Unity 2017.4.23f1 (today it is latest LTS for 2017 series) and I dislike the fact that in order to download AssetStore assets (2D/3D Models for example, that have nothing to do with compatibility) I am required to download them with Unity 2018+ versions, if the asset is uploaded by those above versions.

    I don't want this, being needed to switch to another Unity version kills my productivity (I don't use 2018 and being needed to have a newer version of Unity in computer takes considerable space which does nothing than downloading assets for me and I am in low disk space. I downloaded Unity 2018 in another computer and being needed to transfer the assets from there to work computer takes extra time for users like me), and we are already given LTS ability, therefore I really would like to be able to download assets that have nothing to do with compatibility between versions (2017-2018-2019).

    Many Asset Developers (Mostly 2D/3D models) do not know if they upload their assets with latest Unity, customers won't be able to download them if they do not have latest versions. Instead, if we 'as customers' can download any assets, at least we accept the risks if asset do not work it can be due to incompatibility and even some old assets with scripts work in latest versions too.

    I ask Unity Developers to either grant access to customers (on LTS) to be able to download all assets on AssetStore without restrictions to versions, or informing/restricting asset developers to upload their assets with lowest LTS versions if their work does not contain any scripts but models, textures, etc.
     
  2. GermiyanBey

    GermiyanBey

    Joined:
    Aug 18, 2017
    Posts:
    13
    Bump
    Moderators: Please move this thread where Unity Developers see Feedbacks. As this is related to Asset Store, I shared here, but due to continuous flow of new threads, the feedback is in danger of getting buried in depths without being noticed.

    Asset Customers: Also if this is an issue for you too, please show your support as well and bump the thread.

    Thanks.
     
  3. protopop

    protopop

    Joined:
    May 19, 2009
    Posts:
    1,010
    I’m in unity 5.6 and usually I can buy the assets online that are uploaded in newer version then download them inside Unity. Is that not possible in Unity 2017?

    And I agree with what you are saying. Unity version fragmentation is a real issue when it comes to the asset store, and your suggestion would save a lot of space because developers won’t need to have separate versions of unity installed just to download assets. Also many assets uploaded in later version of unity do indeed work in earlier versions.
     
  4. GermiyanBey

    GermiyanBey

    Joined:
    Aug 18, 2017
    Posts:
    13
    Unfortunately not possible on Unity 2017 and forward. I am able to purchase an asset but can not download it if my version is lower than uploader's version.
    Let's say I am downloading an animation or 3D model or just a texture file that can work in almost any Unity versions (5.5.x-latest) but due to uploader's higher version we are stuck needing to switch to newer versions if we are using an older version. Sometimes need to download latest Unity version in order to download a simple icon pack.
    Very inconvenient.

    Yes I agree, because of this issue (except assets with scripts that needs to be compatible with versions), developers try to upload their assets in different seperate versions too. Inconveniency for everyone sadly.