Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Bug Failing tests because of unity message: Unhandled log message: '[Assert] TLS Allocator ALLOC_TEMP_TH

Discussion in 'Testing & Automation' started by Maeslezo, Oct 17, 2022.

  1. Maeslezo

    Maeslezo

    Joined:
    Jun 16, 2015
    Posts:
    255
    Hello,

    I'm randomly having the following problem:
    When I run an async test, of this kind
    Code (CSharp):
    1.        
    2. [Test]
    3. public async Task DummyAsyncTest()
    4. {
    5. //Arrange
    6. //Act
    7. //Assert
    8. }
    9.  
    I am having a failing test because of this Unity error message:
    Unhandled log message: '[Assert] TLS Allocator ALLOC_TEMP_THREAD, underlying allocator ALLOC_TEMP_THREAD has unfreed allocations, size 192'. Use UnityEngine.TestTools.LogAssert.Expect

    This error appears sometimes when I run it on Unity Editor, but it's much more common from command line in a pipeline.

    I can't figure out neither which is the problem nor a pattern to submit a bug.

    My guessing is that the UTF is allocating some structure for launching the async test, and somehow it's not freed

    Any ideas?

    Further information:
    Test framework: 2.0.1-pre.18
    Unity 2020.3.40
    The tests are in Editor mode

    Thank you