Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  2. Ever participated in one our Game Jams? Want pointers on your project? Our Evangelists will be available on Friday to give feedback. Come share your games with us!
    Dismiss Notice

Failed to start Unity PackageManager

Discussion in 'Package Manager' started by CoolMan1999, Jul 23, 2018.

  1. CoolMan1999

    CoolMan1999

    Joined:
    Jul 13, 2017
    Posts:
    1
    Apologies if this is the wrong place to post this problem.

    I get the error "Failed to start Unity PackageManager: operation timed out" with the (latest?) build of unity 2018.2.0f2 when opening or starting a new project. Antivirus is turned off, firewall turned off, host file has the entry
    127.0.0.1 localhost
    and I tried using
    setx UNITY_NOPROXY localhost,127.0.0.1

    Log file says:
    [Package Manager] Server::Kill -- Server was shutdown
    and
    [Package Manager] Cannot connect to Unity Package Manager local server

    Can someone please help me with this? Unity was working fine before I installed the latest build
     
  2. _karl

    _karl

    Joined:
    Feb 6, 2017
    Posts:
    13
    Unity starts a local npm server, can you check if it is running?
    On Windows it's the upm-win.exe.
     
  3. okcompute_unity

    okcompute_unity

    Unity Technologies

    Joined:
    Jan 16, 2017
    Posts:
    724
    Hi @CoolMan1999,

    Could you share the content of
    upm.log
    log file?

    Regards,

    Pascal
     
  4. Skyfly

    Skyfly

    Joined:
    Jan 25, 2014
    Posts:
    102
    I get an
    {"level":"error","message":"[Unity Package Manager (Upm)]\nParent process [14420] was terminated","timestamp":"2018-08-29T14:26:10.384Z"}
    having the same problem as the guy above.
     
  5. okcompute_unity

    okcompute_unity

    Unity Technologies

    Joined:
    Jan 16, 2017
    Posts:
    724
    HI @Skyfly ,

    This error message is usually thrown by the Package Manager when the parent process (Unity editor) has crashed. Which version of Unity are you using? This log was formatted like this for a few releases in the 2017.x range.

    Regards,

    Pascal
     
  6. Skyfly

    Skyfly

    Joined:
    Jan 25, 2014
    Posts:
    102
    LTS 2017.4.10f1
    I already added upm-win.exe, node.exe and unity.exe to the Norton whitelist.
    Win10
     
  7. Skyfly

    Skyfly

    Joined:
    Jan 25, 2014
    Posts:
    102
    (but it still doesn't work, the error came up with all these things whitelisted)
     
  8. Skyfly

    Skyfly

    Joined:
    Jan 25, 2014
    Posts:
    102
    tried with 2018.2.6f1 and package manager is still not able to start the server. Please, any help? I need to have unity up and running. Right now not a single unity version works. I suspect something blocking net traffic, but I don't know how to find it. I run norton and win10 with latest updates on everything,
     
    d1-favero likes this.
  9. PhilipRit

    PhilipRit

    Joined:
    Mar 26, 2017
    Posts:
    15
    I have the same issue since toda. My package manager does not wonts to load. Followed all tutorials and it does not work.

    Running on a Windows 10 pc, no recent updates but all my Unity Editors starting at 5.6 are broken.
     
    d1-favero likes this.
  10. GenOli

    GenOli

    Joined:
    Apr 21, 2013
    Posts:
    139
    Windows 10 update and restarted PC and now got this, damn.
     
  11. Skyfly

    Skyfly

    Joined:
    Jan 25, 2014
    Posts:
    102
    Please support, don't write it off as 'has nothing to do with unity'
     
    Deegos and d1-favero like this.
  12. GenOli

    GenOli

    Joined:
    Apr 21, 2013
    Posts:
    139
    In my case it was solved by turning off Windows Firewall.
     
    literakl likes this.
  13. literakl

    literakl

    Joined:
    Mar 18, 2018
    Posts:
    7
    My case was Avast firewall blocking the server

    [Package Manager] Cannot connect to Unity Package Manager local server
    [Package Manager] Server::EnsureServerProcessIsRunning -- ReadyRequest exceeded maximum alloted time, ran for [10] seconds
     
  14. okcompute_unity

    okcompute_unity

    Unity Technologies

    Joined:
    Jan 16, 2017
    Posts:
    724
    Thanks for sharing!

    Pascal
     
  15. Gandarufu

    Gandarufu

    Joined:
    Nov 10, 2014
    Posts:
    13
    [2019-12-01T12:27:03.677Z][INFO] Starting Server
    [2019-12-01T12:27:03.682Z][INFO] Server started on port [53704]
    [2019-12-01T12:27:03.959Z][INFO] Health Request received
    [2019-12-01T12:27:14.749Z][ERROR] [Unity Package Manager (Upm)]
    Parent process [15256] was terminated


    I'm starting to become very upset with this, since I'm having the same issues with 2019.3.0b11. One project works fine, the other one won't open until I open it in 2019.2 and then reopen it with 2019.3.

    Does anybody know a fix for this? Why is Unity having problems with one project while another works perfectly fine?
     
  16. CoreyHUN

    CoreyHUN

    Joined:
    Dec 11, 2014
    Posts:
    6
    Same for me, makes me angry
     
  17. V_endeta

    V_endeta

    Joined:
    Mar 31, 2017
    Posts:
    27
    I have the same issue since today.
    Unity 2019.3.0f1 && Unity 2019.2.17f1
    Windiws 10 64bit
    Firewall: off && Defender: off
    No antivirus

    Code (CSharp):
    1. [2020-01-09T20:19:44.447Z][INFO] Opened report file 'C:\ProgramData\Unity\UnityPackageManagerDiagnostics\diagnostic_report_Thu_01_09_2020_211943_70.txt'
    2. [2020-01-09T20:19:44.448Z][INFO] Starting diagnostics
    3. [2020-01-09T20:19:44.450Z][INFO][UpmRegistryReachable] Sending HEAD request to https://packages.unity.com
    4. [2020-01-09T20:19:45.026Z][INFO][PingUpmRegistry] Starting ping test on 'http://packages.unity.com/com.unity.package-manager.metadata'
    5. [2020-01-09T20:19:50.570Z][INFO][PingUpmDownload] Starting ping test on 'http://download.packages.unity.com/com.unity.package-manager.metadata/-/com.unity.package-manager.metadata-0.0.1.tgz'
    6. [2020-01-09T20:19:57.320Z][INFO][UpmRegistryDownloadSpeed] Starting speed test with UPM registry
    7. [2020-01-09T20:20:08.327Z][INFO][UpmRegistryDownloadSpeed] Download: 31.78 Megabits per second
    8. [2020-01-09T20:20:08.329Z][INFO][Speedtest.Net] Starting speed test with Speedtest.net
    9. [2020-01-09T20:20:20.287Z][INFO][Speedtest.Net] Download: 57.39 Megabits per second
    10. [2020-01-09T20:20:20.287Z][INFO][Speedtest.Net] Upload: 8.26 Megabits per second
    11. [2020-01-09T20:20:20.289Z][INFO] Finished diagnostics
    12. [2020-01-09T20:20:20.297Z][INFO] Created report at 'C:\ProgramData\Unity\UnityPackageManagerDiagnostics\diagnostic_report_Thu_01_09_2020_211943_70.txt'
    13.  
     
  18. V_endeta

    V_endeta

    Joined:
    Mar 31, 2017
    Posts:
    27
    After 2 days of trying to start unity I still failed.
    I tried all the ways firewall, windows defender, disabled antivirus, changed unity version, restarted pc, reinstalled unity and hub ...).
    This is incredibly stupid that the user has to do all this in order to use unity, and may not be able to work after all that.
    I do not understand why it happened when everything worked fine until 3 days ago.
    I have reported this bug several times but have not received an answer.
    Is it possible that the unity team doesn't care about this?

    Code (CSharp):
    1. 6 out of 6 checks passed:
    2. [
    3.   {
    4.     "name": "UPM registry reachable",
    5.     "description": "Make an HTTP request to the UPM package registry",
    6.     "result": "PASS",
    7.     "detail": "HTTP/1.1 200 OK\nX-Powered-By: Express\nProvider: Genesis\nDate: Sat, 11 Jan 2020 12:22:45 GMT\nConnection: close"
    8.   },
    9.   {
    10.     "name": "Ping UPM registry",
    11.     "description": "Measure the latency of the UPM package registry API",
    12.     "result": "PASS",
    13.     "detail": "7 pings made in 5.395 seconds\nAverage latency: 133.12 ms\nMinimum latency: 132.06 ms\nMaximum latency: 135.06 ms\nStandard deviation: 1.36"
    14.   },
    15.   {
    16.     "name": "Ping UPM download",
    17.     "description": "Measure the latency of the UPM package download endpoint",
    18.     "result": "PASS",
    19.     "detail": "6 pings made in 5.228 seconds\nAverage latency: 30.39 ms\nMinimum latency: 29.77 ms\nMaximum latency: 31.08 ms\nStandard deviation: 0.66"
    20.   },
    21.   {
    22.     "name": "UPM registry download speed",
    23.     "description": "Test the Internet connection using the UPM package registry",
    24.     "result": "PASS",
    25.     "detail": "Measured speed to the UPM registry: 49.46 Megabits per second"
    26.   },
    27.   {
    28.     "name": "Speedtest.net",
    29.     "description": "Test the Internet connection using Speedtest.net",
    30.     "result": "PASS",
    31.     "detail": "Measured speed to the Speedtest.net server: 58.59 Megabits per second"
    32.   },
    33.   {
    34.     "name": "HTTP proxy environment variables",
    35.     "description": "Detect whether proxy-related environment variables are set (HTTP_PROXY, HTTPS_PROXY, ALL_PROXY, NO_PROXY, UNITY_PROXYSERVER, UNITY_NOPROXY)",
    36.     "result": "PASS",
    37.     "detail": "Proxy support has been configured through the following environment variables:\nUNITY_NOPROXY = localhost,127.0.0.1"
    38.   }
    39. ]
     
  19. V_endeta

    V_endeta

    Joined:
    Mar 31, 2017
    Posts:
    27
    I managed to find a solution to this problem (In my case).
    Basically log out from the unity hub and restart it.
    after that unity will work as normal as before.
     
    Ghat-Smith likes this.
  20. soumyaandpintu

    soumyaandpintu

    Joined:
    Jul 8, 2018
    Posts:
    3
    Same for me
     
  21. soumyaandpintu

    soumyaandpintu

    Joined:
    Jul 8, 2018
    Posts:
    3


    Are you able to solve the problem?
     
  22. soumyaandpintu

    soumyaandpintu

    Joined:
    Jul 8, 2018
    Posts:
    3

    Are you able to solve the problem @Gandarufu
     
  23. thawgyi141059

    thawgyi141059

    Joined:
    Oct 14, 2018
    Posts:
    2
    Well, I've been able to solve this problem and it works for me. But before going through this method, make sure all of your anti-virus programs are turned off and environmental variables are configured.(I already set my HTPP_Proxy, HTPPs_Proxy and UNITY_NOPROXY to localhost,127.0.0.1 which is I'm not sure but I think it's necessary)

    My method is to clone the UnityPackageManager.exe (which is inside the folder of C:\Program Files\Unity\Editor\Data\Resources\PackageManager\Server). But make sure this UnityPackageManager.exe exists in its folder. If you can't find it, you'll have to reinstall the unity. The disappearing of UnityPackageManager.exe is lead to the error of "Failed to start the unity package manager local server process.....". Copy UnityPackageManager.exe and paste into desktop so you can easily access it on later.

    Before opening the projects make sure you have UnityPackageManager.exe in C:\Program Files\Unity\Editor\Data\Resources\PackageManager\Server folder. Constantly monitor the UnityPackageManager.exe inside its folder while opening the projects. The disappearing of UnityPackageManager.exe usually happens at the time of opening projects. If this happens, copy UnityPackageManager.exe that you've cloned on the desktop and try to paste into the folder of UnityPackageManager.exe. It will be disappearing again and again. It'll also throw the error of starting package manager local server and you'll have to copy and paste before retrying.

    Eventually it'll give up and load your project. The error of starting unity package manager local server won't occur until the UnityPackageManager.exe is disappeared from its own folder. If this happens copy and paste UnityPackageManager.exe into its folder.

    My Os version is Window 8.1 pro.
    Also using task manager while opening the projects to monitor which program is deleting UnityPackageManager.exe is helpful.
    If someone has solved this problem in a different way, please share your knowledge.
     
  24. Skyfly

    Skyfly

    Joined:
    Jan 25, 2014
    Posts:
    102
    I bought and setup a new PC. Just in case people wondered if I was able to solve this.
     
  25. supitaUnity

    supitaUnity

    Unity Technologies

    Joined:
    Dec 13, 2019
    Posts:
    81
    hey @thawgyi141059 , this behaviour that you are describing where UnityPackageManager.exe is being deleted looks like caused by a virus or an over-eager antivirus.

    If Windows Defender is the responsible for this, you should be able to track it in its threat history: https://docs.microsoft.com/en-us/wi...-quarantined-files-windows-defender-antivirus

    Do you happen to have any antivirus installed that could be causing this? Maybe something on its quarantine list could help you figure out what's going on.

    If you happen to find who is messing up with UPM, please share it with us :)

    Cheers,

    Supi
     
    lihail123 likes this.
  26. MAVG

    MAVG

    Joined:
    Feb 22, 2018
    Posts:
    11
    Hey!!! it worked!!!
    thanks
     
  27. dozzzl

    dozzzl

    Joined:
    Jul 31, 2013
    Posts:
    12
    It just happened to me, all I did - I moved to new apartment, and now it's not working even though it was working 2 days ago. All solutions posted here didn't help in my case. Any new updates?
     
  28. supitaUnity

    supitaUnity

    Unity Technologies

    Joined:
    Dec 13, 2019
    Posts:
    81
    Hello,Could you please provide the Editor.log and upm.log? To gather these files, please refer to the Log files section in Unity User Manual. https://docs.unity3d.com/Manual/Log...49.673513180.1584294251-1824829955.1575308778

    Cheers,

    Supi
     
  29. centaurianmudpig

    centaurianmudpig

    Joined:
    Dec 16, 2011
    Posts:
    43
  30. supitaUnity

    supitaUnity

    Unity Technologies

    Joined:
    Dec 13, 2019
    Posts:
    81
    I'm not sure you are having the same problem that is described in this thread. As per your logs, the Package Manager connects with the Editor, I see that the log ends in an error, but I'm not sure if it is related to the Package Manager. I also see that you are using 2019.3.2f1, maybe you could try using the latest 2019.3
     
  31. takito

    takito

    Joined:
    Apr 15, 2013
    Posts:
    10
    This is still not resolved...
    That's too bad..
    good luck all...I'm going to UE its free now.

    thanks for everything.
     
  32. Saint-Brady

    Saint-Brady

    Joined:
    May 29, 2015
    Posts:
    1
    I just ran into this issue today when upgrading. Firewall wasn't an issue for me, but I think I accidentally made Hub install during Unity version installation and this caused UPM miss some info. I just deleted the 2019.3.14f1 folder and reinstalled. Worked like a charm.
     
  33. DFT-Games

    DFT-Games

    Joined:
    Jun 24, 2010
    Posts:
    441
    @supitaUnity I have the same problem if I use the WiFi connection while disabling my ethernet port. I have to enable the physical port before to launch Unity (2019.3.15f1), wait for it to start up, then I can disable the port again. Looks a bug in the licensing server.
     
    anthony_unity348 likes this.
  34. supitaUnity

    supitaUnity

    Unity Technologies

    Joined:
    Dec 13, 2019
    Posts:
    81
    I'm sorry to see you are having this issue, could you help us providing more information?

    It will be useful to have the logs from Unity when the problem is present and when it is not, to see if we find any clues about the source of your problem. You can see where to find them here: https://docs.unity3d.com/Manual/LogFiles.html

    If you could include Editor.log, upm.log, but also also the licensing logs (Unity.Entitlements.Audit.log, Unity.Licensing.Client.log) it will be awesome

    Thanks in advance :)
     
  35. DFT-Games

    DFT-Games

    Joined:
    Jun 24, 2010
    Posts:
    441
    Actually my logs are identical to those posted before by the other users: nothing different. It took me quite a while to pinpoint that it happened every time I was tethering on my phone over WiFi.
     
  36. supitaUnity

    supitaUnity

    Unity Technologies

    Joined:
    Dec 13, 2019
    Posts:
    81
    Thanks for the quick reply. What version of Unity are you using?

    I talked to the licensing team and they confirmed me this is a known issue and they are working on a fix for it right now.
     
  37. DFT-Games

    DFT-Games

    Joined:
    Jun 24, 2010
    Posts:
    441
    I'm on 2019.3.15f1, let's hope they fix this :)
     
  38. benjamindavidrichardhasluck

    benjamindavidrichardhasluck

    Joined:
    Apr 7, 2020
    Posts:
    8
    I'm having a problem when I open a project. The server starts running for a few seconds, and then stops and comes up with that message. My Unity version is 2017.4.39f1.
     
  39. benjamindavidrichardhasluck

    benjamindavidrichardhasluck

    Joined:
    Apr 7, 2020
    Posts:
    8
  40. benjamindavidrichardhasluck

    benjamindavidrichardhasluck

    Joined:
    Apr 7, 2020
    Posts:
    8
    Can someone please help me?
     
  41. UnityMaru

    UnityMaru

    Community Engagement Manager Unity Technologies

    Joined:
    Mar 16, 2016
    Posts:
    550
  42. LeleUnity

    LeleUnity

    Joined:
    Jul 30, 2016
    Posts:
    92

    Attached Files:

  43. MAVG

    MAVG

    Joined:
    Feb 22, 2018
    Posts:
    11
    Hey it worked.... thanks
     
  44. DethKwok

    DethKwok

    Joined:
    Mar 13, 2017
    Posts:
    2
    Experiencing a crash on play button in editor,
    [2020-06-22T13:41:54.764Z][ERROR] [Unity Package Manager (Upm)]
    Parent process [30176] was terminated
    Tried logging out and restarting unity, same thing.
     
unityunity