Search Unity

  1. We want you to join us at GDC this year! Take a peek at all of the events we will be hosting during the week of GDC.
    Dismiss Notice
  2. Tell us about your experience here and you’ll get early access to the 2018 Game Studios report + more goodies.
    Dismiss Notice
  3. Unity 2017.3 has arrived! Read about it here.
    Dismiss Notice
  4. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice
  5. We've closed the job boards. If you're looking for work, or looking to hire check out Unity Connect. You can see more information here.
    Dismiss Notice

Failed to import package

Discussion in 'Editor & General Support' started by Agadhnein, Feb 14, 2018 at 5:15 PM.

  1. Agadhnein

    Agadhnein

    Joined:
    Wednesday
    Posts:
    5
    Hello --

    I'm new to Unity and I am trying to go through the basic tutorials. The first basic tutorial (Play and Edit Mode) works fine, but the second one (Game Objects & Components - Rigidbodies to the rescue) gives me an error that says it fails to import the package. I went to the folder and tried opening it up directly from the folder and I get another error message saying that it could not decompress the package ( I assume to open it up in Unity and teach me how to do stuff?).

    Does anyone know how to fix this issue so that it works properly and I can continue with the basic tutorials? Any help would be greatly appreciated.

    Thanks in advance!
     
  2. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    979
    Not knowing which tutorial you are using, what package are you trying to import? What version of Unity? Can you provide a link to the tutorial step?
     
  3. Agadhnein

    Agadhnein

    Joined:
    Wednesday
    Posts:
    5
  4. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    979
    Sorry, without going through the entire tutorial, can you elaborate which package you are trying to import? And Unity version?
     
  5. Agadhnein

    Agadhnein

    Joined:
    Wednesday
    Posts:
    5
    It's the entire package for all of lesson 2 Game Objects and Components in the beginner tutorial section. It can't even open up that lesson from the tutorial at all.

    That being said, Unity did just tell me there's an update required to the newest version, so I'm doing that now and hopefully that will fix the issue :)
     
  6. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    979
    Understood. I see now that you mean the entire tutorial package, not a single package within the tutorial. I just installed it myself on 2017.3, and saw no issues.
     
    Agadhnein likes this.
  7. Agadhnein

    Agadhnein

    Joined:
    Wednesday
    Posts:
    5
    Fantastic. I believe 2017.3 is what my unity is being updated to at the current moment so hopefully the issue will be resolved!

    Thank you very much, Jeff!