Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Failed to deploy package 'Core CLR'

Discussion in 'VR' started by Wilbert-Blom, Mar 31, 2017.

  1. Wilbert-Blom

    Wilbert-Blom

    Joined:
    Aug 13, 2011
    Posts:
    111
    I'm getting an error when trying to deploy to HoloLens or HoloLens emulator:

    Severity Code Description Project File Line Suppression State
    Error DEP6720: Failed to deploy package 'Core CLR' (E0999A8F-0200-4738-AE1E-B45742BE6B6B). Package is not defined for OneCore. Origami


    Using Unity 5.6.0f3 and Visual Studio 2017

    I have no idea how to solve this...
     
  2. Unity_Wesley

    Unity_Wesley

    Unity Technologies

    Joined:
    Sep 17, 2015
    Posts:
    558
    It looks like because you are using Visual Studio 2017, try using Visual Studio 2015 Update 3
     
  3. misher

    misher

    Joined:
    Apr 22, 2016
    Posts:
    19
    I have tryed to deploy with success using VS2017, but now I'm facing the same error. This must depend on something else
     
  4. Unity_Wesley

    Unity_Wesley

    Unity Technologies

    Joined:
    Sep 17, 2015
    Posts:
    558
    Are you using the same Unity build as listed above?
     
  5. misher

    misher

    Joined:
    Apr 22, 2016
    Posts:
    19
    I'm using Unity 5.6.1f1
     
  6. misher

    misher

    Joined:
    Apr 22, 2016
    Posts:
    19
    I have installed VS2015 again, but can not build the solution with SDK 15063, there is a message that I need to update to VS2017. After that I have opened VS2017 and now can build, it is very strange, without VS2015 I had alwayds "Failed to deploy package 'Core CLR'" on deploy.
     
  7. Unity_Wesley

    Unity_Wesley

    Unity Technologies

    Joined:
    Sep 17, 2015
    Posts:
    558
    There have been some recent changes with support in RS3, this might have been the issue you ran into for UWP.