Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Feedback Failed to create a project with UVCS

Discussion in 'Unity Hub' started by Nodrap, Nov 7, 2023.

  1. Nodrap

    Nodrap

    Joined:
    Nov 4, 2011
    Posts:
    80
    So I was just creating a new project (3D URP) and saw the Unity version control system as an option (Hub 3.6.1). Curious, I selected it and tried to create the project. I got the error "There was an issue creating the organization or repository".
    I looked into more information on it and saw I need to sign up for it. So I did this, received the welcome email and tried the create project button once more. Still didn't work, same error.
    I tried creating the repo with the browser interface. The repo was created fine but still no joy.
    I noticed that you need to download a separate app for the UVCS. Ahh this must be the thing missing. I install it. I see the repo created. I try the Create button once more and it still doesn't work. I select the cloud flag in case that is needed, but it still fails with the same vague error message. I have been using the same new project page throughout this process.
    I finally removed the UVCS tick and the project was created. Now I have to work out how I connect it to the repo now.
    Anyone know what I missed?!! The error message should really be more useful.