Search Unity

  1. Calling all beginners! Join the FPS Beginners Mods Challenge until December 13.
    Dismiss Notice
  2. It's Cyber Week at the Asset Store!
    Dismiss Notice

Facebook SDK 7.10.0 Importing Problem

Discussion in 'Scripting' started by InfinityCoder88, Aug 21, 2017.

  1. InfinityCoder88

    InfinityCoder88

    Joined:
    Oct 4, 2013
    Posts:
    245
    Hi friends,

    I'm using Unity 2017.1.0p3 , and I try to import in my new created project (empty project) latest Facebook SDK 7.10.0, but I got a problem, I'm getting this error in editor:

    error CS1704: An assembly with the same name `Facebook.Unity.Settings' has already been imported. Consider removing one of the references or sign the assembly
    Library/FacebookSDK/Facebook.Unity.Settings.dll (Location of the symbol related to previous error)
    Assets/FacebookSDK/Plugins/Settings/Facebook.Unity.Settings.dll (Location of the symbol related to previous error)

    Compilation failed: 1 error(s), 0 warnings

    Anybody have a clue why the FB SDK doesn't work or how to fix this issue?
    Thanks in advance!
     
  2. Brathnann

    Brathnann

    Joined:
    Aug 12, 2014
    Posts:
    4,750
    Unity actually includes a sdk selector in their player settings now. I noticed in in 2017.1.0p4 when it told me to that there was 7.10.1 available to select. I'm guessing there is still something odd going on as it looks like when you install an sdk, it should overwrite the selection. In my case, I had the sdk installed already so it's showing that it overwrites it. You may just try selecting that build target and then choosing an fb sdk from the player settings.

    I did try selecting one and got some weird error also, but it might be because I was on the Android platform. You may also simply be able to delete the Facebook.Unity.Settings.dll file.

    I haven't played around with this enough yet to see how good it works.
     

    Attached Files:

    InfinityCoder88 likes this.
  3. platinio2007

    platinio2007

    Joined:
    Jul 17, 2015
    Posts:
    17
    Any work on this? i am stuck with the same problem, and i try to delete one of the two dlls, and later i get something about gpm data and when compiling on android come some problems about mergin Manifest.xml, and yes facebook has his onw SDK, for the Facebook platform i can import facebook into my scripts but dont has all the code so dont work correctly, and once you import FB sdk you can no select any FB sdk in the dropdown menu but any way thahs only affect FB platform, some what i will try later today is reinstall Unity and uncheck FB platform and maybe Unity willl no install the uncompleted FB sdk for FB platform and no more problems i hope. i will let you know
     
  4. Brathnann

    Brathnann

    Joined:
    Aug 12, 2014
    Posts:
    4,750
    Well...that's one heck of a run on sentence. I barely understand what you are saying.

    The merging manifest issue is pretty common and while it can be annoying, it's generally easy to solve.

    Beyond that, I'm not sure what you are actually saying honestly. I haven't tried a new build with the FB sdk in the drop down menu. The copy I had was already installed in the project and the project was updated several times into new versions of Unity, so I never noticed the drop down menu till recently.