Search Unity

Bug Everything Pink in Unity 2019.1.0f2 linux editor except Menu bar

Discussion in 'Linux Editor' started by flyingorcus, Apr 17, 2019.

  1. flyingorcus

    flyingorcus

    Joined:
    Sep 23, 2018
    Posts:
    3
    I installed Unity 2019.1.0f2 from hub. But having some UI issues when using editor. Except for Menu bar [File, Component, etc.], everything else is pink.
    OS: Ubuntu 16.04

    Thanks in advance for any help.
     
    Last edited: May 5, 2019
    k0nfus1us, hadisajjadi and rayzote like this.
  2. rayzote

    rayzote

    Joined:
    Jan 30, 2019
    Posts:
    3
    Same here. I filled up a bug report. The unity editor log shows a persisten error when compiling shaders (a lot of shaders fail compiling), which I believe to be the root of the problem:
    0:22(1): error: uniform explicit location requires GL_ARB_explicit_uniform_location and either GL_ARB_explicit_attrib_location or GLSL 3.30.

    OS: Manjaro (Arch Linux), KDE
    Dell Latitude E6430s

    The error above does not happen on my Unity 2018.3 projects. However, when I try to open new projects in Unity 2019.1 it always gives this error.

    I have OpenGL 4.2, and Intel integrated graphics. When I check glxinfo, it seems to include both attributes/extensions mentioned in the error line. Is it not detecting them? or am I misinterpreting what glxinfo is telling me.

    I've attached the example of how the Unity editor looks like, a screenshot of the Unity Log, and some outputs from glxinfo.
     

    Attached Files:

    k0nfus1us likes this.
  3. hadisajjadi

    hadisajjadi

    Joined:
    Feb 7, 2018
    Posts:
    5
    Same Here i was very happy that unity moved to preview but right after opening project in unity i faced with pink editor except menubar
    os:Lubuntu 18.10 (Ubuntu based)
     
  4. k0nfus1us

    k0nfus1us

    Joined:
    Apr 15, 2019
    Posts:
    1
    I have the same issue with this update. Previously installed version 2018.3 worked for me.
    I'm using Arch Linux + Intel graphics (Ivy Bridge), OpenGL 4.2
     
  5. rayzote

    rayzote

    Joined:
    Jan 30, 2019
    Posts:
    3
    I filled up a bug report. They told me it affects those with Intel HD 4000 graphics.

    Here is what they told me.
     
    k0nfus1us likes this.
  6. hadisajjadi

    hadisajjadi

    Joined:
    Feb 7, 2018
    Posts:
    5
    yes i have intel 4000 graphic what the hell we gonna do now? just protend that linux version doesn't exist and use wine?
    or windows version is pink too on windows?
     
  7. shomz

    shomz

    Joined:
    Nov 9, 2016
    Posts:
    5
    Pink is the new dark mode.
    I love it how they don't give a damn about it. Hopefully someone with a clear mind fixes it in the next patch.

    Downgrading to 2018.3.14f1 works fine.
     
    Last edited: Apr 27, 2019
    moaz0004 likes this.
  8. ArtmanGames

    ArtmanGames

    Joined:
    Oct 3, 2018
    Posts:
    3
    no i tried 2019.2 and that is pink too. unity please fix this
     
  9. Snipe76

    Snipe76

    Joined:
    May 23, 2017
    Posts:
    10
    Try installing Vulkan and forcing it in the Project Player settings.
    OpenGL is problomatic with HDRP and LWRP.
    Vulkan works with it.
     
    PixelJ and FROS7 like this.
  10. rayzote

    rayzote

    Joined:
    Jan 30, 2019
    Posts:
    3
    I switched to Windows 10 for unrelated reasons, and tried Unity 2019 again. It seems to work! I don't know why! It is the same version.
    I have Intel HD4000.

    I can't find the log file to see if it showed any errors. The LWRP Editor didn't show any errors in console, while the HDRP showed a couple of warnings, which I think are only related to my graphics' performance.
    I attached two images, one of the LWRP, and the other is the HDRP editor.
     

    Attached Files:

  11. ArtmanGames

    ArtmanGames

    Joined:
    Oct 3, 2018
    Posts:
    3
    yeah i have windows 7 and it works there but we want to work with linux
     
  12. rocky1138

    rocky1138

    Joined:
    Aug 13, 2012
    Posts:
    27
    Has this been fixed? I'm experiencing this issue with the newest version :(
     
  13. graham_twae

    graham_twae

    Joined:
    May 27, 2016
    Posts:
    1
    It works in version 2019.3.0a3. Although the window frame/border is missing. But it is still usable.
    So the pink screen bug is fixable.
     
    Last edited: May 25, 2019
  14. afsalrahman51

    afsalrahman51

    Joined:
    May 19, 2019
    Posts:
    3
    How can i do that .?.. especially when i can't open any settings menu in unity which is filled with pink color .
    projects setting , snap settings , preference nothing can be opened . only a pink box appears (even in about window).
    i have installed Vulkan and is there any way to force Unity to use Vulkan against OpenGL ?
     
  15. afsalrahman51

    afsalrahman51

    Joined:
    May 19, 2019
    Posts:
    3
  16. haidarvm

    haidarvm

    Joined:
    Jul 23, 2017
    Posts:
    1
    I just download it from Unity Hub or Download version 2019.2.0b10 it's works fine

    I'm using Red Hat Enterprise Linux 8 with Intel Core i3 3320M, Intel HD 4000

     
  17. reflipd

    reflipd

    Joined:
    Jun 4, 2019
    Posts:
    5
    Open Unity Hub go to the project listing, Advanced Setting type in -force-vulkan
     
  18. moaz0004

    moaz0004

    Joined:
    May 22, 2017
    Posts:
    5