Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Every mesh in Unity 5 scene editor covered in impenetrable fog

Discussion in 'Editor & General Support' started by Kinkku2, May 26, 2015.

  1. Kinkku2

    Kinkku2

    Joined:
    Sep 29, 2014
    Posts:
    106
    Hey, I'm having a bit of a problem. Every mesh I have in my Unity's scene view is covered by a greenish fog as if they had a material that looked like that or like there was an intense fog covering them. I've checked my lighting options and there's no global fog active. In game view the meshes have their assigned colors and everything looks fine.

    How could I go about fixing this?
     
  2. Kinkku2

    Kinkku2

    Joined:
    Sep 29, 2014
    Posts:
    106
    A bit of an update: The meshes render perfectly in scene view if they have a texture that is imported from outside. If they have a material that is a solid color (created within Unity) the scene view does not render the color but instead a green sort of replacement texture.

    Edit: Ok, I solved it. It was a bit simpler than I thought! I opened the dropdown menu in the left upper corner of the scene view and figured out that I didn't have a shading mode chosen. So I just clicked shaded.
     
    Last edited: May 27, 2015
unityunity