Search Unity

  1. Get the latest news, tutorials and offers directly to your inbox with our newsletters. Sign up now.
    Dismiss Notice

Ever since 2020.2.1f1 -- VS can't see any C# files in the plugins folder (Case 1308758)

Discussion in 'Editor & General Support' started by quitebuttery, Jan 24, 2021.

  1. quitebuttery

    quitebuttery

    Joined:
    Mar 12, 2011
    Posts:
    308
    So I have this issue where VS can't see anything in the plugins folder -- I first noticed it when for some reason it couldn't see any of the PoolManager classes. The game still ran in the editor, but VS reported all these errors when you tried to build for debugging.

    I moved the PoolManager out of the plugins folder and into the root Assets folder and that fixed it.

    But it doesn't fix the hundreds of errors I have because Steamworks etc. is in there--I have a lot of plugins with C# files in the plugins folder that VS can't see. Is there a way to force VS to see this folder or is this a legit bug?

    I've tried updating VS 2017, using VS 2019, rebuilding the project, reloading all the projects. Nothing works. Please help--I submitted this as case (Case 1308758) with sort of a misleading description as I thought it was an intellisense bug, but it's actually preventing builds.

    Oh also, one other thing, it doesn't seem to be able to see compiler directives like #UNITY_EDITOR etc. either.

    This was all working fine in 2020.1
     
    Last edited: Jan 24, 2021
unityunity