Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

"events.js:174 Unhandled 'error' event" when trying to start websocket

Discussion in 'Unity Render Streaming' started by Deleted User, Apr 26, 2022.

  1. Deleted User

    Deleted User


    I've been trying and struggling to get the webserver to run properly.
    Each time I run the .\webserver -w command, I get the following error:

    WebApp>.\webserver -w
    start websocket signaling server ws://
    start as public mode
    throw er; // Unhandled 'error' event

    Error: listen EACCES: permission denied
    at Server.setupListenHandle [as _listen2] (net.js:1263:19)
    at listenInCluster (net.js:1328:12)
    at Server.listen (net.js:1415:7)
    at Function.listen (C:\snapshot\WebApp\node_modules\express\lib\application.js:618:24)
    at new RenderStreaming (C:\snapshot\WebApp\build\index.js:0:0)
    at (C:\snapshot\WebApp\build\index.js:0:0)
    at Object.<anonymous> (C:\snapshot\WebApp\build\index.js:0:0)
    at Module._compile (pkg/prelude/bootstrap.js:1433:22)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:787:10)
    at Module.load (internal/modules/cjs/loader.js:651:32)
    Emitted 'error' event at:
    at Server.emit (events.js:198:13)
    at emitErrorNT (net.js:1307:8)
    at process._tickCallback (internal/process/next_tick.js:63:19)
    at Function.runMain (pkg/prelude/bootstrap.js:1489:13)
    at startup (internal/bootstrap/node.js:320:19)
    at bootstrapNodeJSCore (internal/bootstrap/node.js:660:3)
    I've tried using the webserver.exe downloaded via the Unity Download web app command using 3.1.0-exp.3 on two separate machines now, with the exact same result. Is there a step I'm missing or some configuration that needs to change?

    Thanks, and let me know if more info would be useful.
  2. kazuki_unity729


    Unity Technologies

    Aug 2, 2018
  3. Deleted User

    Deleted User


    Port 80 reserved on windows, and I didn't feel like messing with that, so I went ahead and set up a cert/key pair and got the https approach working!