Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Error when trying to connect project.

Discussion in 'Unity Collaborate' started by Caliber-Mengsk, Jun 7, 2016.

  1. Caliber-Mengsk

    Caliber-Mengsk

    Joined:
    Mar 24, 2010
    Posts:
    689
    I hadn't updated the beta in a little while (was on b17), and the collaborate button didn't work, so I updated to the newest version of the beta (b20) and it said it couldn't properly link the account or something like that. Sorry for being so vague, but I don't remember exactly what it said, I had it not link after an update before, and just manually going through the process worked just fine. I figured it was simply cause of the editor update, but now when trying to manually link it, I set the organization and the project, and click the "link" button, I get this not so descriptive error:

    SSL: couldn't create a context: error 140a90f2:lib(20):func(169):reason(242)

    Not sure what it means, but I'm sure it means something to the devs. It's not super important that this project be updated to collab, but at the moment, I can't do anything as far as collab is concerned.

    Is it simply just the servers being down for updates or something?
     
  2. andyk-unity

    andyk-unity

    Unity Technologies

    Joined:
    Dec 11, 2013
    Posts:
    37
    Hi @Caliber Mengsk ! Seems like there were several issues here, let's try to narrow things down.

    1) Collaborate button didn't work - Does this mean it was greyed out? Did Collaborate ever work for you?
    2) Project being unlinked - Was it the button that says "restore access" or did you go through the "select org -> select project" linking process?
    3) Do any of the other services work for you currently, or is it just Collaborate that's down?

    As to that error, that's a new one to me. I'll send it around to see if anybody has an idea. Would you happen to have your editor log file still from that? Might have a clue as to what happened.
     
  3. Caliber-Mengsk

    Caliber-Mengsk

    Joined:
    Mar 24, 2010
    Posts:
    689
    Collaborate button was grayed out, and it was working before (uploaded just fine). It was doing the select organization, select project, and when I selected both and glicked link, it gave that error. The only other service I have enabled is the multiplayer service, and from what I could tell, it was working, but I'm using my own built matchmaking (just not using the built in matchmaking, and redirecting to different ip's through php scripts and www objects). So I'm not certain. I also noticed that after the upgrade, some of the prefabs were text document icons and couldn't be brought into the scene. I did a full reimport and that fixed both of the issues. (I make backups between updates, so it wasn't a massive deal)

    It seems to be working now that I did the full re-import. I don't have the logs anymore (been like a week at this point). I would guess the update just messed up and it couldn't access files or something was missing that needed to be there between the two different beta versions.
     
unityunity