Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Error when pressing Start

Discussion in 'FPS.Sample Game' started by CaioRosisca, Oct 25, 2018.

  1. CaioRosisca

    CaioRosisca

    Joined:
    Sep 19, 2012
    Posts:
    4
    Hi, I followed all the steps on the Getting Started guide but when I hit the final Start button this error shows up.
    How can I solve it?
     

    Attached Files:

  2. DougRichardson

    DougRichardson

    Joined:
    Oct 7, 2017
    Posts:
    74
    Are you running a 32-bit version of Windows? According to the log messages, it looks like the network bindings were only compiled for 64-bit.
     
  3. kelfire

    kelfire

    Joined:
    Mar 9, 2017
    Posts:
    9
    You have to change "Architecture" to x86_64 inside "File->Build Setting..."
     
  4. CaioRosisca

    CaioRosisca

    Joined:
    Sep 19, 2012
    Posts:
    4
    I'm running 64bit, trying to change Architecture on build settings now and coming back to see if it works, might as well rebuild all assets if it doesn't just to make sure. So might take a while
     
  5. CaioRosisca

    CaioRosisca

    Joined:
    Sep 19, 2012
    Posts:
    4
    Solved, thanks @kelfire I changed the build settings to 64. But needed to rebuild all bundles and game to make it work
     
  6. amack2u

    amack2u

    Joined:
    Dec 22, 2016
    Posts:
    2
    that solved my issue as well and should be added to the docs of the fps sample