Search Unity

Error when installing Burst Package

Discussion in 'Package Manager' started by Grendelbiter, Jul 1, 2019.

  1. Grendelbiter

    Grendelbiter

    Joined:
    Oct 14, 2016
    Posts:
    115
    Hello,

    so I upgraded an old project to the newest Unity build (a07). Everything went fine until I added Vegetation Studio pro. That requires the Burst package so I installed that. As soon as I installed I got this error:

    Code (CSharp):
    1. Library\PackageCache\com.unity.burst@1.0.4\Editor\BurstAotCompiler.cs(638,32): error CS7036: There is no argument given that corresponds to the required formal parameter 'exceptionType' of 'BuildReport.AddMessage(LogType, string, string)'
    The Burst package doesn't show up in the package manager anymore so it's unremovable. I tried deleting it manually but Unity just adds it again.

    I then tried a new project, only adding the Burst package (and dependencies), same error. It does show up in the package manager though in the fresh project.

    Anyone else with this problem? Do I just have to wait for the next Unity update?
     
  2. okcompute_unity

    okcompute_unity

    Unity Technologies

    Joined:
    Jan 16, 2017
    Posts:
    527
    HI @Grendelbtier,

    I believe I got the same error and the burst developer told me to install a previous version. Have you tried with Burst 1.0.2 or less?

    Regards,

    Pascal
     
  3. Grendelbiter

    Grendelbiter

    Joined:
    Oct 14, 2016
    Posts:
    115
    I have and I get the same error plus another one:

    Code (CSharp):
    1. Library\PackageCache\com.unity.burst@1.0.0\Editor\BurstAotCompiler.cs(358,62): error CS0117: 'AndroidArchitecture' does not contain a definition for 'X86'
     
  4. Grendelbiter

    Grendelbiter

    Joined:
    Oct 14, 2016
    Posts:
    115
    @okcompute_unity your suggestion brought me to try out the Burst preview.3 -1.1.0 and that works (after I deleted a bunch of scripts that were complaining, luckily just from examples I don't really need)

    Thank you
     
  5. Grendelbiter

    Grendelbiter

    Joined:
    Oct 14, 2016
    Posts:
    115
    I spoke too soon, my game worked in the editor but I couldn't build. I then tried the most recent one Preview.5 0.2.4 and that worked...kinda. Unity froze up when completing building then my whole pc froze up when I tried to kill the Unity task. The build didn't work either. The second time building worked although there were 4 errors all related to Burst. It worked though, the build ran fine.