Search Unity

  1. Check out the Unite LA keynote for updates on the Visual Effect Editor, the FPS Sample, ECS, Unity for Film and more! Watch it now!
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Error: Unity-iPhone has conflicting provisioning settings

Discussion in 'Unity Cloud Build' started by Max_power1965, Nov 21, 2016.

  1. Max_power1965

    Max_power1965

    Joined:
    Oct 31, 2013
    Posts:
    55
    Hello,
    I was trying to use cloud build to build my iOS game, but I get this error:

    "Unity-iPhone has conflicting provisioning settings. Unity-iPhone is automatically signed, but provisioning profile Unity_provProf_cloud_build has been manually specified. Set the provisioning profile value to "Automatic" in the build settings editor, or switch to manual signing in the project editor."

    I don't know what happened but it was working.

    The team id and the bundle ID are both set. What is the problem?

    Thanks
     
  2. dannyd

    dannyd

    Unity Technologies

    Joined:
    Jun 3, 2014
    Posts:
    746
    Are you running any kind of post-process on the Xcode project after it's exported from Unity (or relying on any plugins that might)?

    With Xcode 8 came some changes to the signing process and this generally means there are some conflicting settings (or a problem with the way we are injecting some provisioning settings because of some incompatibility).

    For now, you can switch to Xcode 7.3 and continue building until we can figure out why this is happening for your builds.
     
  3. Max_power1965

    Max_power1965

    Joined:
    Oct 31, 2013
    Posts:
    55
    You're right, It works with Xcode 7.3.
    The problem is started after I've imported a PlugIn.
    Let me know if you need more info in order to help you guys to fix the problem.
    Thanks
     
  4. dannyd

    dannyd

    Unity Technologies

    Joined:
    Jun 3, 2014
    Posts:
    746
    @Max_power1965: We just deployed a fix for this issue in Xcode 8. Let me know if you have a chance to test that.
     
  5. Max_power1965

    Max_power1965

    Joined:
    Oct 31, 2013
    Posts:
    55
    @dannyd is working. Thanks Man!
     
  6. Cenda

    Cenda

    Joined:
    Jun 3, 2010
    Posts:
    50
    It looks that bug is back with current version 2018.1.0f2
     
  7. SofielafeeApps

    SofielafeeApps

    Joined:
    Mar 26, 2018
    Posts:
    2
    same problem here with 2018.1.0f2, amy idea?
     
  8. jose-araujo

    jose-araujo

    Joined:
    Nov 17, 2016
    Posts:
    24
    Same problem on 2018.1.0f2
     
  9. Stephan-Rehfeld

    Stephan-Rehfeld

    Joined:
    Dec 23, 2015
    Posts:
    1
    @Guillaume42 & @jose-araujo
    It looks to me that the signing configuration that is created by the Builder of 2018.1.0f2 differs from what XCode 9.3.1 expects. I fixed the problem by adjusting the signing information of the project. To do so do the following steps:
    1. Select the top level node called Unity-iPhone in the left tree view (the one with the blue item).
    2. Select Automatically manage signing
    3. Select your team (now the error message should appear)
    4. Go to Build setting in the tab
    5. Find the Group called "signing" in the structured table
    6. Change the values from "iPhone Developer" to "iOS Developer"
    7. Switch back to general (the error message should now disappear)

    Your project should compile now and should be runnable on your iPad or iPhone.
     
  10. unity_1_nq7Cwi5IZ7hQ

    unity_1_nq7Cwi5IZ7hQ

    Joined:
    May 16, 2018
    Posts:
    3
    [MY SOLUTION BELOW]

    Same problem on 2018.1.0f2 as well.

    It initially worked to set to "Automatically manage signing" and I successfully deployed the game to my iPhone.
    But then I created a new build from Unity and tried the same trick on xCode, but it's not working anymore. It gives me the error "Unity-iPhone has conflicting provisioning settings."


    [MY SOLUTION]

    Look at the picture I attached to see what I did: I've set the "Build Settings" in that way (for each target).
    I also did "Product -> Clean", but I'm not sure yet if it's needed
     

    Attached Files:

    Last edited: May 23, 2018
    W4rf4c3 likes this.
  11. JamesBaud007

    JamesBaud007

    Joined:
    Aug 10, 2013
    Posts:
    2
    I was previously using Unity 2017.3.0f3 and everything had worked just fine, but after upgrading to 2018.1.3f1, I encountered the same issue mentioned above. While the proposed solutions by Stephan-Rehfeld and unity_1_nq7Cwi5IZ7hQ did address the issue, it was not a practical solution for me because I use Jenkins to create my Unity builds.

    I found an alternate solution that does not need to be performed manually for every build. Launch the Unity Editor and select "Edit" > "Preferences..." from the menu. In the "External Tools" tab, enter your iOS Team ID into the "Signing Team Id" field.

    Even though I had my "Signing Team Id" specified directly in my "Project Settings" (which used to work as expected in Unity 2017.3.0f3), it now only seems to work in Unity 2018.1.3f1 if the team ID is specified in the "External Tools" menu.
     
    Neikke likes this.
  12. HouseFrog

    HouseFrog

    Joined:
    Jan 14, 2016
    Posts:
    11
    It started for me after updating to the latest version of GameAnalytics SDK (4.0.5)

    It also solved it for me changing the signing values to ios dev
     
  13. KangJiwon

    KangJiwon

    Joined:
    May 13, 2018
    Posts:
    1
    I love you
    You saved me.............
     
  14. Neikke

    Neikke

    Joined:
    Jun 23, 2017
    Posts:
    66
    Thanks! Worked for me!