Search Unity

  1. Check out our Unite Austin 2017 YouTube playlist to catch up on what you missed. More videos coming soon.
    Dismiss Notice
  2. Unity 2017.2 is now released.
    Dismiss Notice
  3. The Unity Gear Store is here to help you look great at your next meetup, user group or conference. With all new Unity apparel, stickers and more!
    Dismiss Notice
  4. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice
  6. Unity 2017.3 beta is now available for download.
    Dismiss Notice

Error retrieving information from server. [RPC:S-5:AEC-0]

Discussion in 'Android' started by TMK, Jan 18, 2013.

  1. TMK

    TMK

    Joined:
    Mar 29, 2010
    Posts:
    83
    I solved this myself, but I wanted to make this thread just in case others experience it, as I didn't find a solution on Google for my exact problem.

    I've been implementing Prime31's Google Play In-App-Billing on a new unreleased game. The in-app-purchases used to work fine in my test build, but then I started getting the following error message when attempting to purchase an in-app-purchase:

    Error retrieving information from server. [RPC:S-5:AEC-0]

    This was shown on the "Play Store" purchase screen. I tried to reset my phone, delete my account on my phone, clear Play Store apps cache like a lot of people suggested when I Googled this, but none of it worked.

    However, the problem was that I had just uploaded a new build to the Google Play developer console. It seems like you have to wait 1+ hour for it to get properly updated for new build versions. After waiting, it worked fine. But I could have saved a lot of time and problem solving if I had known that! :)

    This must be something that only happens on the newer Play Store versions, as I've implemented In-App-Purchases before, and uploaded a new build tested it right after, and it worked fine on those.