Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Error on editor Microsoft (R) Visual C# Compiler version 2.9.1.65535 (9d34608e) (Unity 2019.1.9f1)

Discussion in 'Editor & General Support' started by VeinLeint, Jul 26, 2019.

  1. VeinLeint

    VeinLeint

    Joined:
    Feb 4, 2016
    Posts:
    4
    Hi,

    I'm been having this issue for 4 days now. Things go like this:

    I have a Unity project that whenever I open it, some errors show up, saying only " Microsoft (R) Visual C# Compiler version 2.9.1.65535 (9d34608e)" When you select the error, nothing more is shown. No data or clue where to fix the issue. 15 of these errors show up. After some searching, I found out that if I remove the packages installed through the package manager, 14 of these errors disappear, but 1 remains.

    The thing is, I need all of the packages that I remove, so if I put them back, the 15 errors show again. And even if I delete them, the last one doesn't disappear.

    With these errors, I cannot even put "play" or do much on the editor.

    Things I have try:
    • Deleting the project and download it again.
    • Reimport all assets
    • Unistall unity and install it again.
    • Search for the same error on internet (9d34608e).
    • Open a new project with the same Unity version (the errors do appear even in this new project which contains nothing).
    • Reinstall java.
    • Check Editor log, which displays this:
    Mono: successfully reloaded assembly - Completed reload, in 10.610 seconds
    [ScriptCompilation] Recompiling all scripts because: Reload of assemblies failed, assemblies are invalid or forced recompiled
    Microsoft (R) Visual C# Compiler version 2.9.1.65535 (9d34608e)
    Copyright (C) Microsoft Corporation. All rights reserved.
    And that is pretty much it.

    Here is how the error is displayed on the editor (as you can see, it doesn't show anything of what is actually wrong):
    image.png

    Thanks to anyone reading this and willing to help. I'm on a big hole on this issue.
     
    Franco211 likes this.
  2. Franco211

    Franco211

    Joined:
    Jul 26, 2019
    Posts:
    1
    Same error here, let me know if you figure out how to fix it
     
  3. rohantech

    rohantech

    Joined:
    Aug 27, 2019
    Posts:
    1
    Same! Been at this for 2 weeks now. Getting this error also on mac OSX Mojave 10.14.3.

    Error is:
    Code (CSharp):
    1. Microsoft (R) Visual C# Compiler version 2.9.1.65535 (9d34608e)
    2. Copyright (C) Microsoft Corporation. All rights reserved.
    3.  
    4. error CS0009: Metadata file '/Applications/Unity/Hub/Editor/2019.1.14f1/Unity.app/Contents/NetStandard/compat/2.0.0/shims/netstandard/System.Reflection.dll' could not be opened -- Read out of bounds.
    5.  
    upload_2019-8-27_23-14-40.png

    Have tried all of the following but keep getting the same core error:
    • completely uninstalled Unity twice and Visual Studio 2019 (+ ensuring have Visual Studio for Mac Tools for Unity Version 2.2.0.0)
    • fresh installs of 2019.1.14f1 and 2019.2.2f1
    • fresh projects from templates, 3D, LWRP and from Unity github samples - like AR Foundation
    • all combinations of mono/IL2CPP, Scripting Runtime .Net 4.x and 3.5 & Api Compatibility .Net Standard 2.0 and 4.x
    • tried renaming folders like suggested https://forum.unity.com/threads/mic...08e-copyright-c-microsoft-corporation.668395/
    Problem seems to have come out of nowhere. Nothing works. Unity is effectively bricked. Can someone please help I'm going nuts lol?
     
  4. AUGMENTX

    AUGMENTX

    Joined:
    Jun 14, 2019
    Posts:
    4
    same error on 2019.2.3f1. Seems to work fine on booting but updating a package (in this case LWRP) causes error. Didn't show it in video but after i added other packages and got more errors of the same.
    Anyone know how to resolve?
    2019.1 and 2019.2.2f1 both had the error from the start however in 2019.2.3f1 it seems package change dependant. upload_2019-9-1_0-4-22.png
     
  5. dardamavet

    dardamavet

    Joined:
    Oct 7, 2014
    Posts:
    4
    Same for me.
    I worked on 2019.2.2f1 with no problem (Windows 10), but suddenly this error started and I can not compile anything anymore, not even on an empty new project.
    I did installed VS2019 lately, but it worked.
    Perhaps it have something to do with the installation of Spyder for python? seems unrelated, but the installation did warn me about Environment-Variables risky changes.
    I uninstalled Unity, and re-installed Unity 2019.2.5f1, as well as 2019.3(beta), as well as re-installed visual studio 2019, nothing helped.

    My unity 2018.3.8f1 still works correctly.
     
    Last edited: Sep 15, 2019
  6. smerch3000o

    smerch3000o

    Joined:
    Sep 11, 2019
    Posts:
    1
    Hi. I have exactly the same problem and I also recently installed Spyder.

    Can someone help me? I really need to keep working, but I can't even build an empty project.
     
    dardamavet likes this.
  7. techie2200

    techie2200

    Joined:
    Jul 10, 2015
    Posts:
    1
    Same error over here.
     
  8. mcroswell

    mcroswell

    Joined:
    Jan 6, 2010
    Posts:
    54
    2019.11 same problem.
     
  9. mcroswell

    mcroswell

    Joined:
    Jan 6, 2010
    Posts:
    54
    After an hour or so, of looking at file permissions, noting that they were fine (read or even read/write), that the file existed, even when Unity said it didn't. I almost gave up. Unity is really making a mess of things with the Hub, in my opinion.

    Regardless, I have _a_ solution - though:
    1) it really depends on what DLL it was complaining about, but in my case it was from a project over a year old which I tried to open (and Unity automatically converted - but not very well apparently) and
    2) this is just based on my trial and error and who knows if it's even close to the right thing to do!

    The new version of Unity I used was 2019.2.11f1 Personal Edition and using the Hub 2.1.3.

    I did try some other stuff (like removing the Visual Studio Package and reinstalling from Unity), but it seems this was the solution (and one we should not be expected to do as end-user in my oh so humble opinion):

    It was complaining about System.Collections.dll in some huge path. I found the file by right clicking on the Unity App (under hub) in the File Manager and said Show Contents. The actual path I have when doing an "Info" is:
    /Applications/Unity/Hub/Editor/2019.2.11f1/Unity.app/Contents/MonoBleedingEdge/lib/mono/4.7.1-api/Facades

    Anyway, my solution was to steal the whole 4.7.1-api folder from an earlier version (see snap shot below) of Unity (also by using Show Contents in File Manager):
    upload_2019-11-10_19-52-57.png

    Anyway, I don't understand, and am rather peeved I had to waste so much time. I wanted to share so you would at least have some kind of solution, though this is Unity's problem (or should be) not ours.

    For what it's worth, I had to do this with another directory with two other DLL's (each time shutting down Unity and the HUB and restarting to find the new locations). I was just lucky this approach works, I think. FYI, the other directory was somewhere like:/Applications/Unity/Hub/Editor/2019.2.2f1/Unity.app/Contents/NetStandard/compat/2.0.0/shims/netstandard

    Same trick. Just replaced all of that netstandard sub-directory ( I recall! )
     
  10. tweedie

    tweedie

    Joined:
    Apr 24, 2013
    Posts:
    278
    Unfortunately I doubt this will be of much help, but FWIW the only time I've seen this error is when a file makes use of some C# features that Unity (or, presumably, mono) doesn't yet support/ is unable to compile (most obviously C#8 features like switch expressions). Either way, it's a very unhelpful error message.