Search Unity

  1. Looking for a job or to hire someone for a project? Check out the re-opened job forums.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

ERROR ITMS-90503 using 2019.4.7

Discussion in 'iOS and tvOS' started by alan_motionlab, Aug 18, 2020.

  1. alan_motionlab

    alan_motionlab

    Joined:
    Nov 27, 2014
    Posts:
    99
    Hi,

    I'm trying up update my game from cloud build, but when I try to send the build to Apple using fastlane, I get the following:

    Code (csharp):
    1. parameter ErrorMessage = ERROR ITMS-90503: "Invalid Bundle. You've included the "arm64" value for the UIRequiredDeviceCapabilities key in your Xcode project, indicating that your app may only support 64-bit.
    I'm not setting anything specifically for arm64 anywhere in my code. I have Universal selected as the Architecture in the project settings. My first release of the game was build using Unity 2019.4.5f1 and Xcode 11.4.1, with no complaints. I'm not really sure how to go about fixing this issue. I use cloud build for my releases so don't have access to change the Xcode project directly (though could through post script if required)

    If this is more a cloud build issue, please move over.

    Anyone else had this issue and know how to fix it?
     
  2. nicolasgramlich

    nicolasgramlich

    Joined:
    Sep 21, 2017
    Posts:
    231
    Exact same issue on
    2019.4.8f1
    :(
     
  3. nicolasgramlich

    nicolasgramlich

    Joined:
    Sep 21, 2017
    Posts:
    231
    Alright, changing these settings allow uploading to Apple again. Make sure that
    Valid Architectures
    has only arm64 stuff in it:

    upload_2020-8-18_19-34-26.png

    I think it's because Unity bumped the min iOS version around
    ≈2019.4.5f1
    . There's probably a setting on the Unity side as well, so that you don't have to do this for every single build.
     
    Propagant and ADNCG like this.
  4. Kujo87

    Kujo87

    Joined:
    Sep 16, 2013
    Posts:
    139

    Yeah, I use cloud build, so would definitely like a way to do this programmatically
     
  5. AlexNanomonx

    AlexNanomonx

    Joined:
    Jan 4, 2017
    Posts:
    34
    Got this issue on cloud build too. I assume it's a bug introduced in version 2019.4.6/7? I submitted the last version of my app with 2019.4.5 which worked, so I'm going to revert. Has anyone created a issue around this? It's pretty important for an LTS release for unity to get this fixed.
     
  6. alan_motionlab

    alan_motionlab

    Joined:
    Nov 27, 2014
    Posts:
    99
    I've tried a few things now and no matter what, Unity adds in arm64. I've tried post build scripts to set an empty array, to also set armv7, but Unity always seems to get the last work and add in arm64 which means I can't use cloud build update a game.

    I did try downgrading (only on cloud) to unity 2019.4.5 as you suggested @AlexNanomonx, but it didn't work. I may need to try downloading that version and properly downgrade my project and push it.
     
  7. AlexNanomonx

    AlexNanomonx

    Joined:
    Jan 4, 2017
    Posts:
    34
    @alan_motionlab That's frustrating. I should confirm that it did work for me.
     
  8. alan_motionlab

    alan_motionlab

    Joined:
    Nov 27, 2014
    Posts:
    99
    I'll try properly downgrading things rather than just letting Cloud deal with it.
     
  9. maxim_kornilov

    maxim_kornilov

    Joined:
    May 29, 2018
    Posts:
    5
    I had the same issue after updating to 2019.4.7.

    To fix it, you need to update iOS player settings for your unity project. It is necessary to set 'Architecture' to ARM64 value in iOS player settings.
     
  10. Kujo87

    Kujo87

    Joined:
    Sep 16, 2013
    Posts:
    139

    My game is live so I’m not able to do that, as it’s rejected. I’ve managed to fix it with a post build script and remove arm64 from the requirements
     
    andymads likes this.
  11. andymads

    andymads

    Joined:
    Jun 16, 2011
    Posts:
    1,550
    I have submitted a bug report #1278534.
     
  12. jerome-lacoste

    jerome-lacoste

    Joined:
    Jan 7, 2012
    Posts:
    184
  13. maxim_kornilov

    maxim_kornilov

    Joined:
    May 29, 2018
    Posts:
    5
  14. ash22

    ash22

    Joined:
    Jan 4, 2014
    Posts:
    1
    Had the same issue on 2019.4.11 - old version was already supporting arm7 and arm64 - The way to fix that worked for me:
    1. add opengles2 and opengles3 under the metal on the graphics api (uncheck the auto graphics api)
    2.in architecture select arm64 only

    thanks for posting people
     
  15. VitaSkr

    VitaSkr

    Unity Technologies

    Joined:
    Jul 2, 2019
    Posts:
    14
    Hi everyone,

    Thank you all for sharing your findings and accept our apologies for taking a bit longer than expected to look into this.

    You can track the progress on a chosen resolution in our public Issue Tracker: https://issuetracker.unity3d.com/product/unity/issues/guid/1271078

    @ash22 Many thanks for sharing your workaround, I've added it to the bug report.

    Warmest Regards,
    Vita
    Customer QA Team
     
  16. idlemath

    idlemath

    Joined:
    Feb 18, 2015
    Posts:
    10
    We're running into this issue as well.

    @VitaSkr the link included in your post is not working - any updates on a resolution?
    upload_2020-10-7_18-57-8.png
     
  17. VitaSkr

    VitaSkr

    Unity Technologies

    Joined:
    Jul 2, 2019
    Posts:
    14
    @idlemath This issue was marked as non-public what makes the Issue Tracker's link invalid. Fix for this issue is currently under the verification process it should be fixed in 2019.4.13f1.
     
    Last edited: Oct 8, 2020
    EtienneMarbotic likes this.
  18. magasset

    magasset

    Joined:
    Oct 24, 2016
    Posts:
    4
    Hi @VitaSkr do we have an ETA on 2019.4.13f1 as we are affected by this bug
     
  19. VitaSkr

    VitaSkr

    Unity Technologies

    Joined:
    Jul 2, 2019
    Posts:
    14
    @magasset We published 2019.4.13f1 yesterday
     
    Last edited: Nov 2, 2020
    joonturbo and nicolasgramlich like this.
  20. Midiphony

    Midiphony

    Joined:
    Jan 25, 2019
    Posts:
    6
    I have a similar issue on Unity 2018.4.24f1, preventing me from submitting a major update to one of our app :(

    I am getting the following error :
    Our live app has the "armv7" UIRequiredDeviceCapability. But since recently, Unity replaces the 'armv7" string with "arm64" in the final build. The Info.plist inside the XCode project is fine, but the .ipa has "arm64" and not "armv7" in UIRequiredDeviceCapabilities.

    No matter what I do (editing plist's UIRequiredDeviceCapabilities in XCode or during PostProcess), the "arm64" UIRequiredDeviceCapability is added and "armv7" is removed. This prevents me from making an important update of an app.

    I also noticed this happens when the minimum iOS version targeted is 11. It stops happening when the minimum iOS version targeted is set back to 10 but we cannot use this "workaround".

    Does anyone have a fix or a workaround ? Is anything planned or done for Unity 2018 ?
     
    Last edited: Oct 31, 2020
  21. unity_06gc1oztsPFawQ

    unity_06gc1oztsPFawQ

    Joined:
    May 25, 2018
    Posts:
    1
    For anyone still having this issue prior to Unity 2019.4.12, here is what I had to do.

    1- Close xcode
    2- Open your Info.plist file on your favourite text editor
    3- Search for "UIRequiredDeviceCapabilities" and delete all instances of "<string>arm64</string>" you find
    4- Open xcode and re-submit your app

    Hope this helps!
     
  22. ziyochiii

    ziyochiii

    Joined:
    Feb 11, 2020
    Posts:
    1
    This solved my problem:
    1. open Info.plist as source code upload_2020-12-4_11-42-14.png
    2. Find 'UIRequiredDeviceCapabilities' and delete everything in the red rectangle.
    upload_2020-12-4_11-44-25.png
     
unityunity