Search Unity

“Error DEP6957 Failed to connect to device using Universal Authentication” when deploying Unity app

Discussion in 'Windows' started by otto_mejia, Feb 28, 2019.

  1. otto_mejia

    otto_mejia

    Joined:
    Feb 18, 2019
    Posts:
    4
    Hi all,
    I've been working in a Unity app with Hololens emulator in Visual Studio 2017 in Windows Pro, and it was working great until last night where I started to get the following issue every time that I try to deploy my application into the Hololens emulator:

    Error DEP6957 : Failed to connect to device '[device_ip]' using Universal Authentication. Please verify the correct remote authentication mode is specified in the project debug settings.

    I've tried to do the following things without success:
    • Clean/rebuild solution
    • Checked 'uninstall/install' checkbox in the UWP project settings
    • Deleted Hololens virtual machine
    • Uncheck/check Hyper-v feature (and restart PC after each try)
    • Restarted computer
    No luck. Sometimes, I am able to make it work, but after 30 seconds to 1 minute, the hololens emulator gets frozen and then it closes itself; again, this was working fine until last night, and I have not installed anything different, unless an automatic windows update did something. This happens with all the applications, and they run just fine in the Unity player.

    I would appreciate your help on this, I just don't think the only solution is to uninstall/install Visual studio and all its components, it makes no sense, since everything was ok.

    Thank you.