Search Unity

Help Wanted error CS0234, CS0246, CS0308, CS0115 - FIXED

Discussion in 'Package Manager' started by unitedone3D, Sep 5, 2021.

  1. unitedone3D

    unitedone3D

    Joined:
    Jul 29, 2017
    Posts:
    91
    https://stackoverflow.com/questions...ty-version-2019-1-12f1-and-now-have-62-errors

    Hey there!

    I am trying to fix a problem with the Package Manager causing me head aches (worked perfectly last week, now decided does not want to anymore and suddenly popped up errors by itself that were not there before);

    I am getting 137 errors in the console, they are related to the (apparently) the Unity Recorder (supposedly), and I have installed the Unity Recorder repeatedly, I tried the last version 3.0.1, and I tried the 'preview version' 2.0.1...makes no difference, when I restart Unity, same 137 errors there...

    See the pictures to see whole list of errors:
    CS0234
    CS0246
    CS0308
    CS0115

    I also installed the Visual Studio Code - in Editor Settings...it's there...Unity Recorder is Installed too...tried the last version (3.0.1) and the preview version (2.0.1)...no difference, does not work.

    I tried to change the manifest.json file -> ''com.unity....package - recorder'' ''3.0.1''..I forced Unity to reinstall it..and it did reinstalll like that...made no difference, errors still there.

    99% of the errors are of the 'UI' type....UI is intalled already. All the packages required (I believe) are already installed...the errors still show up in console?

    What is this problem?

    I tried to find answers, and sure enough found a trillion threads relating to this Unity Recorder problem/conflict calling 'older incompatible version?' of package manager/scripts, don't know, as the cause of it...or is it the 'Visual Studio Code' thing....anyway. The answers there. I tried them, nearly all, no difference.

    On this page:
    https://stackoverflow.com/questions...ty-version-2019-1-12f1-and-now-have-62-errors

    Unity responded and said that it was a Unity Recorder package manager version conflict or something...

    I already did that (install/reinstall/remove...recorder) and changed nothing. The errors are still there...

    I also tried to delete the .csproj files and sln (solution) files to force Unity to remake them...made no difference.

    On that link above, some reimported All the Assets...and changed nothing...I am not going to Reimport thousands of assets (hours), I would wish to avoid that, before having to do that (in the person's case...it did not help/did not change anything wether reimporting everything).

    It is a problem with the package manager conflicting with some (old?) package (version?) or Unity is 'injecting' stuff in the scripts somehow and thus causes the ''are you missing an assembly thing??''...

    Should I just delete the whole Packages/Library..in entirety? Total Wipe out..only solution?

    As anyone had/having same problem? How did you fix it? Unity...please do you have any idea?

    Any help is greatly appreciated,

    Thank you very much.
     

    Attached Files:

    Last edited: Sep 5, 2021
  2. unitedone3D

    unitedone3D

    Joined:
    Jul 29, 2017
    Posts:
    91
    PS: Found the solution:

    The culprit is ''com.unity.manager-package-ui'' and its scripts;

    this package is not needed (the other "com.unity.modules.ui" & "com.unity.modules.uielements" are installed by default);
    remove it, find ''C:\Unity..\(Your)ProjectXYZ\Library\PackageCache\com.unity.manager-package-ui'' folder, delete it.
    Open manifest.json with notepad (C:\Unity..\(Your)ProjectXYZ\Packages\manifest.json),
    remove ''com.unity.manager-package-ui'' in the list. Restart Unity, this will fix all these errors (which were all related to this specific package problem).
     
unityunity