Search Unity

Error: Attribute meta-data#com.google.ar.core.min_apk_version@value value=(180226000) from [:core-1

Discussion in 'Editor & General Support' started by ARBMP, Jan 11, 2019.

  1. ARBMP

    ARBMP

    Joined:
    Dec 17, 2018
    Posts:
    1
    issues, edited the Androidmanifest with no progress or change... PLEASE help! :)

    GRADLE ERROR : colliding-attributes
    UnityEngine.GUIUtility:processEvent(Int32, IntPtr)


    stderr[
    C:\Users\kylpe\Documents\RadARBMP\BVX\Temp\gradleOut\src\main\AndroidManifest.xml:41:13-38 Error:
    Attribute meta-data#com.google.ar.core.min_apk_version@value value=(180226000) from [:core-1.1.0:] AndroidManifest.xml:41:13-38
    is also present at [:core-1.3.0:] AndroidManifest.xml:43:13-38 value=(180525000).
    Suggestion: add 'tools:replace="android:value"' to <meta-data> element at AndroidManifest.xml:39:9-41:41 to override.

    Code (CSharp):
    1. <supports-screens
    2.         android:anyDensity="true"
    3.         android:largeScreens="true"
    4.         android:normalScreens="true"
    5.         android:smallScreens="false"
    6.         android:xlargeScreens="true" />
    7.  
    8. <application
    9.         android:label="@string/app_name"
    10.         android:icon="@drawable/app_icon">
    11.     <activity android:name="com.unity3d.player.UnityPlayerActivity"
    12.               android:configChanges="fontScale|keyboard|keyboardHidden|locale|mnc|mcc|navigation|orientation|screenLayout|screenSize|smallestScreenSize|uiMode|touchscreen">
    13.         <intent-filter>
    14.             <action android:name="android.intent.action.MAIN" />
    15.             <category android:name="android.intent.category.LAUNCHER" />
    16.         </intent-filter>
    17.     </activity>
    18.     <meta-data tools:replace="android:value" android:name="com.google.ar.core" android:value="required" />
    19. </application>
    20. </manifest>
    21.