Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Question error Android: Targeting API '31' with architecture 'arm64', ABI 'arm64-v8a'

Discussion in 'VR' started by SP4ZE, Apr 20, 2024.

  1. SP4ZE

    SP4ZE

    Joined:
    Jul 31, 2022
    Posts:
    9
    Hey, trying to build to Android device (Oculus Quest 2) which is using **API level 32**

    When Im trying to set minimum and target API to 33, or 34, im getting this error :
    Software of device 'Oculus Quest 2 (...)' is not supported: Device: ... [Quest 2]
    The connected device is running Android with API level 32, while minimum API level of the project is set to 34. Please change the project settings or connect a device with Android version not lower than the one set in the project settings.


    When i set my minimum and target API to 32 or lower im getting this error :
    [CXX1405] error when building with cmake using C:\Users\...\Desktop\...\Library\Bee\Android\Prj\IL2CPP\Gradle\unityLibrary\src\main\cpp\CMakeLists.txt: -- Android: Targeting **API '31'** with architecture 'arm64', ABI 'arm64-v8a', and processor 'aarch64' See the Console for details.

    That was the building pop up error, this is the console error:
    CommandInvokationFailure: Gradle build failed.
    C:\Program Files\Unity\Hub\Editor\2023.2.18f1\Editor\Data\PlaybackEngines\AndroidPlayer\OpenJDK\bin\java.exe -classpath "C:\Program Files\Unity\Hub\Editor\2023.2.18f1\Editor\Data\PlaybackEngines\AndroidPlayer\Tools\gradle\lib\gradle-launcher-7.6.jar" org.gradle.launcher.GradleMain "-Dorg.gradle.jvmargs=-Xmx4096m" "assembleRelease"


    when i paste it in terminal, im getting:
    At line:1 char:133
    + ... e\lib\gradle-launcher-7.6.jar" org.gradle.launcher.GradleMain "-Dorg. ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Unexpected token 'org.gradle.launcher.GradleMain' in expression or statement.
    + CategoryInfo : ParserError: :)) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : UnexpectedToken

    Ive tried every minimum / target API level out there, including both 32. Inside CMakeLists.txt, ive added the following
    # Set the target API level
    set(CMAKE_ANDROID_API 32)


    Also tried rebuilding the Library folder, using version 2023.2.18f1

    I have the required SDK and NDK versions, any help would be greatly appreciated

    Any help is greatly appreciated
     
  2. SP4ZE

    SP4ZE

    Joined:
    Jul 31, 2022
    Posts:
    9
    After reinstalling the SDK with android studio, and changing the API minimum and target settings, im now also getting

    Errors during XML parse:
    System.Threading.ThreadHelper:ThreadStart ()


    Additionally, the fallback loader failed to parse the XML.
    System.Threading.ThreadHelper:ThreadStart ()

    :(