Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Bug Error "400 Bad Request" when I try to login into Unity Ads

Discussion in 'Unity Ads & User Acquisition' started by _geo__, Jul 25, 2022.

  1. _geo__

    _geo__

    Joined:
    Feb 26, 2014
    Posts:
    1,246
    I have a reoccuring problem with the Unity Ads login.

    I can can login fine if I start a new browser session (aka private tab). But if I am already logged in (for example in the forums or the publisher backend) then I get a blank page. The browser debug view tells me it's a "400 bad request" error. The annonying thing is, once this has happens I can no longer access any unity related website, they all return 400 errors. I then have to DELETE all unity cookies to make it work again.

    Repro steps:
    1) Login into the forum or publisher backend.
    2) Access https://dashboard.unity3d.com/organizations/[myid]/projects/[myproject]/monetization/ad-units?providerType=existingexclusive
    3) Get a 400 bad access error (I think it fails at some sort of global redirect after/at login).
    4) Go into browser settings and delete all unity cookies
    5) Log in on the ads website. Now it works.

    Sometimes after the unity ads login the forum starts returning 400 errors (and sometimes it does not). So it seems to work the other way around too. Though the most reliable way for me to reproduce it is to be logged in to the forum first and then try the ads login.

    I have tried every cookie accept/reject combination I can think of, none works.

    I've had this for a couple of weeks now and was hoping it would get fixed eventually but it's getting really annoying. Anyone having simular issues?

    Thanks