Search Unity

  1. Going to #UniteBerlin? Bring a buddy & get 25% off the 2nd ticket! More info here.
    Dismiss Notice
  2. Famed game designer and creator of The Sims, SimCIty, and Spore is looking for a 3D artist to join their team. Join the challenge.
    Dismiss Notice
  3. Unity 2017.4 has arrived! Read about it here.
    Dismiss Notice
  4. ARCore is out of developer preview! Read about it here.
    Dismiss Notice
  5. Magic Leap’s Lumin SDK Technical Preview for Unity lets you get started creating content for Magic Leap One™. Find more information on our blog!
    Dismiss Notice
  6. We've opened a new World Building sub-forum to faciltate all your world building discussions! Drop in and ask any ProBuilder, ProGrids, or PolyBrush questions.
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Equi Angular youtube videos in 2018 player?

Discussion in '2018.1 Beta' started by Fonefen, Apr 16, 2018 at 1:55 PM.

  1. Fonefen

    Fonefen

    Joined:
    Dec 30, 2012
    Posts:
    2
    Is it possible to play Equi Angular youtube videos from the unity 2018 player?
     
  2. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    688
    Equi Angular projection isn’t supported outside the box, but you could write your own shaders to do it. However, bridging with YouTube is not doable right now, not legally anyways. You can possibly scrape the YouTube player web app to get actual movie URLs but, apart from the fact this goes most probably against their EULA, you’d also be missing the YouTube features such as dynamic resolution switching, adjustments for target platform and picking URL suitable for the user’s current location.
     
  3. Spanky11

    Spanky11

    Joined:
    Mar 9, 2015
    Posts:
    239
    Regarding playing Youtube videos, is anyone else having problems? I'm using an asset that retrieves the correct youtube streaming URL, and then uses a Video Player to play the video. In Unity 2018.1b13, this *sometimes* works, but very often the Video player doesn't play the video. As far as I can tell I'm doing everything correctly. When I cut and paste the URL into a browser, the video plays fine. I've tried disabling and re-enabling the Video player. I've tried pausing and then playing the video. Nothing seems to work. I believe 2017 didn't have this problem because everything was working fine for me in 2017 and now it's broken in the lastest 2018 beta. Anyone have any thoughts?


    upload_2018-4-17_14-10-7.png