Search Unity

  1. Unity 2019.1 beta is now available.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We're looking for insight from anyone who has experience with game testing to help us better Unity. Take our survey here. If chosen to participate you'll be entered into a sweepstake to win an Amazon gift card.
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Unity 2018.3 is now released.
    Dismiss Notice
  6. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Enabling Cinemachine; all shadows go away ?!

Discussion in 'Cinemachine' started by DiscoFever, Dec 5, 2018.

  1. DiscoFever

    DiscoFever

    Joined:
    Nov 16, 2014
    Posts:
    201
    When I add a simple Cinemachine virtual camera; all my shadows go away !?!
    Is this a bug? Did someone else experience the same issue ?
     
  2. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    2,056
    Cinemachine only animates the Camera's transform and lens setting. It doesn't touch anything else. I suspect that you have inadvertently enabled a new Camera which hides your real one. Can you show me your project hierarchy, with all cameras and vcams visible?
     
  3. Adam_Myhill

    Adam_Myhill

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    320
    Cinemachine does let you set near and far clip planes on the camera. Check to make sure the CM values match whatever you had on your main camera. That could be a possibility as the clip plane settings affect shadow resolution