Search Unity

Audio Empty Scene + Audio Source + Audio Listener = Silence?!

Discussion in 'Audio & Video' started by Zergling103, Oct 10, 2019.

  1. Zergling103

    Zergling103

    Joined:
    Aug 16, 2011
    Posts:
    284
    I am running into trouble with the most basic audio set up:

    My scene is a brand new, empty scene with a default camera + audio listener set up. I've added an audio source with a looping sound near the camera.
    • Audio listener
      • Positioned at 0, 1, -10
      • Enabled
    • Audio source is
      • Positioned at 0, 0, 0
      • Audio Clip: Loopable white noise
      • Output: None/Master (New Audio Mixer) (Neither option made a difference.)
      • Mute: Off
      • Bypass Effects: On
      • Bypass Listener Effects: N/A
      • Bypass Reverb Zones: On
      • Play On Awake: On
      • Loop: On
      • Priority: Default (128)
      • Volume of 100%
      • Pitch of 100%
      • Stereo Pan: 0 (No left/right bias)
      • Spacial blend: 100% 2D.
      • Reverb Zone Mix: 0%
      • Doppler Level: 0%
      • Volume Roloff: Log, Range 400-500
    • Audio Clip
      • Generated white noise
      • Audible when played in the editor by clicking the file in the project view.
    • Windows' audio mixer does not have the editor muted. When clicking on the audio file in the project view, the audio file can be heard in the inspector.
    • Using an Audio Mixer did not make a difference in audability. However, while used, the Audio Mixer displayed activity in the "Master" audio visualization (peaking at -10 dB). All settings on the audio mixer are set to their defaults.
    This is probably the least complicated scenario to troubleshoot audio with, yet the only way I can hear audio is through the editor's audio inspection when clicking on a audio file. I'm kinda baffled, help would be appreciated.

    I've recently moved onto Unity 2019 after working in Unity 5.6. If a new feature was introduced which broke the previous audio workflow, I'm not aware of it.
     
  2. Zergling103

    Zergling103

    Joined:
    Aug 16, 2011
    Posts:
    284
    It turns out, there's a new... feature... where by default audio is muted in the editor. To unmute it, you have to find the Game view and unclick the easy-to-miss-if-you-don't-know-where-to-look "Mute Audio" button.

    >_> Why is this muted by default...?
     
unityunity