Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Question EditorXR is chunky, stuttering in an empty scene

Discussion in 'EditorXR' started by Steven_VR, Feb 5, 2021.

  1. Steven_VR

    Steven_VR

    Joined:
    Jan 11, 2020
    Posts:
    8
    I am using:
    2019.4.19f1
    EditorXR 0.4.12
    The old (recommended) input system
    The old (recommended) XR system
    with
    - VivePro
    - RXT2080ti
    - i9 9900k

    I open a scene with a simple object and start EditorXR
    Everything works fine and smooth with me just looking around, but the moment I touch a wand - Everything is juttery, chunky, laggy.
    CPU is at 3%, GPU at 10% so it does not seem to be horsepower.

    The more I use it - the worse it gets and will never recover (e.g. it's not a matter of letting go of the wands and all is good... once those wands come to life - it is a laggy mess).
    If I select an object in a scene... forget it. It is so slow.
    Again CPU and GPU are not even blinking.
    When I "Play" the scene - no problem... crazy fast.

    Also as I use it - more and more help tab callouts shed and populate over the scene. ("press to undo" and "trigger for...")
    They get detached from the controllers over time and float in space in various sizes.
    If I close EditorXR and reopen - It's nice and fast again.... until I touch a controller.
    <repeat>

    I have tried multiple installs of Unity 2019.4
    I have tired new projects and re-adding the package.

    Always the same.
    Any suggestions?
    S.
     
  2. amirebrahimi_unity

    amirebrahimi_unity

    Unity Technologies

    Joined:
    Aug 12, 2015
    Posts:
    400
    Somehow missed this thread. Were you able to resolve? Have you tried any other Unity versions? Does standard Unity VR play-mode (not EditorXR in play mode) run well?