Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  2. Ever participated in one our Game Jams? Want pointers on your project? Our Evangelists will be available on Friday to give feedback. Come share your games with us!
    Dismiss Notice

Editor still crashing (hub running editor not)

Discussion in 'Linux Editor' started by KiaZmtb, Apr 20, 2020.

  1. KiaZmtb

    KiaZmtb

    Joined:
    Apr 12, 2020
    Posts:
    4
    System : Ubuntu 14.04 LTS 64 bit
    Unity release : Unity-2019.1.0f2
    Unity Hub works, but when trying to create a project and launch editor it crashes after displaying the attached window.
    Command line log:

    ./Unity
    /tmp/.mount_UnityHpSpl8H/unityhub-bin: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by /tmp/.mount_UnityHpSpl8H/unityhub-bin)
    /tmp/.mount_UnityHpSpl8H/unityhub-bin: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by /tmp/.mount_UnityHpSpl8H/unityhub-bin)
    Fontconfig warning: "/etc/fonts/fonts.conf", line 86: unknown element "blank"
    [0420/104302:ERROR:browser_main_loop.cc(161)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
    ATTENTION: default value of option force_s3tc_enable overridden by environment.
    [0420/104303:ERROR:browser_main_loop.cc(207)] Gtk: gtk_window_present_with_time: assertion 'GTK_IS_WINDOW (window)' failed
    kiaz@kiaz-MacBookAir:~/Unity-2019.1.0f2/Editor$ [Unity Package Manager (Upm)]
    Parent process [3306] was terminated

    Editor.log :

    Desktop is 1366 x 768 @ 60 Hz
    [Package Manager] Server::Start -- Port 43650 was selected

    COMMAND LINE ARGUMENTS:
    /home/kiaz/Unity-2019.1.0f2/Editor/Unity
    -createproject
    /home/kiaz/Unity-2019.1.0f2/New 2
    -cloneFromTemplate
    /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/ProjectTemplates/com.unity.template.2d-2.3.1.tgz
    -cloudOrganization
    undefined
    -cloudEnvironment
    production
    -useHub
    -hubIPC
    -hubSessionId
    f045d6b0-82e2-11ea-a724-ddd50d3ecab7
    -accessToken
    oVLFFM5GjML2g1NongCpZAfT5GbqTJ6AEl4ADaaOXjU001f
    /home/kiaz/Unity-2019.1.0f2/New 2
    Using Asset Import Pipeline V1.

    LICENSE SYSTEM [2020420 10:50:54] Next license update check is after 2020-04-21T08:43:03

    Loading GUID <-> Path mappings...0,000125 seconds
    Loading Asset Database...0,000017 seconds
    AssetDatabase consistency checks...0,000158 seconds
    [Package Manager] Done resolving packages in 0,71s seconds
    [Package Manager] Registering 38 packages:
    [Package Manager] * Package : com.unity.ads@2.0.8
    (location: /home/kiaz/Unity-2019.1.0f2/New 2/Library/PackageCache/com.unity.ads@2.0.8)
    [Package Manager] * Package : com.unity.analytics@3.3.2
    (location: /home/kiaz/Unity-2019.1.0f2/New 2/Library/PackageCache/com.unity.analytics@3.3.2)
    [Package Manager] * Package : com.unity.collab-proxy@1.2.16
    (location: /home/kiaz/Unity-2019.1.0f2/New 2/Library/PackageCache/com.unity.collab-proxy@1.2.16)
    [Package Manager] * Package : com.unity.package-manager-ui@2.1.2
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.package-manager-ui)
    [Package Manager] * Package : com.unity.purchasing@2.0.6
    (location: /home/kiaz/Unity-2019.1.0f2/New 2/Library/PackageCache/com.unity.purchasing@2.0.6)
    [Package Manager] * Package : com.unity.textmeshpro@2.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/New 2/Library/PackageCache/com.unity.textmeshpro@2.0.0)
    [Package Manager] * Package : com.unity.timeline@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.timeline)
    [Package Manager] * Package : com.unity.modules.ai@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.ai)
    [Package Manager] * Package : com.unity.modules.animation@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.animation)
    [Package Manager] * Package : com.unity.modules.assetbundle@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.assetbundle)
    [Package Manager] * Package : com.unity.modules.audio@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.audio)
    [Package Manager] * Package : com.unity.modules.cloth@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.cloth)
    [Package Manager] * Package : com.unity.modules.director@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.director)
    [Package Manager] * Package : com.unity.modules.imageconversion@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.imageconversion)
    [Package Manager] * Package : com.unity.modules.imgui@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.imgui)
    [Package Manager] * Package : com.unity.modules.jsonserialize@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.jsonserialize)
    [Package Manager] * Package : com.unity.modules.particlesystem@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.particlesystem)
    [Package Manager] * Package : com.unity.modules.physics@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.physics)
    [Package Manager] * Package : com.unity.modules.physics2d@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.physics2d)
    [Package Manager] * Package : com.unity.modules.screencapture@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.screencapture)
    [Package Manager] * Package : com.unity.modules.terrain@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.terrain)
    [Package Manager] * Package : com.unity.modules.terrainphysics@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.terrainphysics)
    [Package Manager] * Package : com.unity.modules.tilemap@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.tilemap)
    [Package Manager] * Package : com.unity.modules.ui@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.ui)
    [Package Manager] * Package : com.unity.modules.uielements@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.uielements)
    [Package Manager] * Package : com.unity.modules.umbra@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.umbra)
    [Package Manager] * Package : com.unity.modules.unityanalytics@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.unityanalytics)
    [Package Manager] * Package : com.unity.modules.unitywebrequest@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.unitywebrequest)
    [Package Manager] * Package : com.unity.modules.unitywebrequestassetbundle@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.unitywebrequestassetbundle)
    [Package Manager] * Package : com.unity.modules.unitywebrequestaudio@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.unitywebrequestaudio)
    [Package Manager] * Package : com.unity.modules.unitywebrequesttexture@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.unitywebrequesttexture)
    [Package Manager] * Package : com.unity.modules.unitywebrequestwww@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.unitywebrequestwww)
    [Package Manager] * Package : com.unity.modules.vehicles@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.vehicles)
    [Package Manager] * Package : com.unity.modules.video@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.video)
    [Package Manager] * Package : com.unity.modules.vr@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.vr)
    [Package Manager] * Package : com.unity.modules.wind@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.wind)
    [Package Manager] * Package : com.unity.modules.xr@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.modules.xr)
    [Package Manager] * Package : com.unity.ugui@1.0.0
    (location: /home/kiaz/Unity-2019.1.0f2/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.ugui)
    [Package Manager] Done registering packages in 0,04s seconds
    Refreshing native plugins compatible for Editor in 0,01 ms, found 0 plugins.
    Preloading 0 native plugins for Editor in 0,00 ms.
    IsTimeToCheckForNewEditor: Update time 0 current 1587372655
    Initialize engine version: 2019.1.0f2 (292b93d75a2c)
    GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event
    GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event
    [vulkan] LoadVulkanLibrary libvulkan.so.1[vulkan] LoadVulkanLibrary failed to load libvulkan.so.1Vulkan detection: 0
    GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event
    GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event
    GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event
    GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event

    Is there any opportunity of making unity running or I have to buy a new laptop? (I'm planning to buy one but not so early)

    I hope someone can give me any clue.
    Thanks in advance
    K.
     

    Attached Files:

    Eskibrew likes this.
  2. Eskibrew

    Eskibrew

    Joined:
    Apr 20, 2020
    Posts:
    4
    I have the same problem - on LinuxMint 18.3 (64 bit). I have two laptops with this OS and it works on one but not on the other. I suspect therefore it is not a problem with LinuxMint but a missing pre-requisit.

    How did you get the command line info? - I have Unity Hub installed - are you starting Unity Hub from the command line?

    Edit: I ended up removing the UnityHub which I'd installed from the ubuntu repo and instead used the AppImage downloaded. It may be coincidence that this made it work but worth trying.
     
    Last edited: Apr 21, 2020
  3. KiaZmtb

    KiaZmtb

    Joined:
    Apr 12, 2020
    Posts:
    4
    I start editor from command line, editor launches HUB, and then editor dies when HUB is trying to re-launch editor to open/create a project. I have downloaded everything from unity website (hub by AppImage) and it happens both launching editor first or hub first. Having an old version of ubuntu and a not-so-new laptop I would like to try - if possible - with an older version of unity. Otherwise I will wait and buy a new laptop as soon as possible.
     
unityunity