Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Editor loop at 100% (100ms+) on 2020.1.0b3, 2020.1.0b2

Discussion in 'Linux Editor' started by P0150N, Apr 1, 2020.

  1. P0150N

    P0150N

    Joined:
    Aug 1, 2015
    Posts:
    8
    Anyone else having issues with the beta editor where there is a constant lag (feels around 15 FPS), and when using the profiler, the Editor loop is at 100% usage?

    The profiler only shows that the overall is 100%, and no single process is responsible for it.

    Note: I am using Arch Linux with i3 window manager.

    I know Arch is not supported, but this issue does not exist on 2019.3.5f1, it only happens on the 2020 Beta editors. I am wondering if any other Arch users are experiencing the same thing with the latest Beta editor.

    For reference, I install all my editors using the Unity Hub package on AUR: https://aur.archlinux.org/packages/unityhub/

    I also attached a screenshot of what it shows in the Hierarchy of the profiler.

    Edit: Tested on newest 2020.1.0b4, issue still occurs. Also, issue occurs regardless of using OpenGL or Vulkan, editor is still at 15 FPS or less.

    2020-03-31_19-11.png
     
    Last edited: Apr 2, 2020
  2. P0150N

    P0150N

    Joined:
    Aug 1, 2015
    Posts:
    8
    For anyone else that will or might have this obscure problem in the future, here's a solution that doesn't make sense but it worked anyways:

    1. Go to Edit > Preferences
    2. In the general section, find "Interaction Mode" (should be at the way bottom)
    3. Set the value to "Monitor Refresh Rate" (mine was set at "No throttling")

    CPU was instantly freed up in the editor, and the issue does not occur anymore.

    Edit: Here's a 100% way to reproduce the problem:

    1. Same section in general
    2. Set the value to "Not throttling" (nothing will happen)
    3. Restart editor
    4. When the editor re-launches, the editor will be very slow and at 100+ ms on CPU. Follow above instructions and it will fix itself
     
    toyhunter likes this.
  3. jonathans42

    jonathans42

    Unity Technologies

    Joined:
    Jan 25, 2018
    Posts:
    276
    Hi P0150N, is it possible that you have something in your project that triggers some infinite repaints of some editor windows? If you have a project to share that would be nice, so we can investigate this further.

    Thanks,
     
  4. Guirao

    Guirao

    Joined:
    Nov 24, 2012
    Posts:
    68
    Hello I am experiencing the same problem but on 2019.3.9f1. The game is running and the profiler is the editor one, taking almost 100 ms. It seems that most of the time is waiting for gfx.

    The suggested fix from P0150N didn't work.
     

    Attached Files:

    Lopost likes this.
  5. MartinTilo

    MartinTilo

    Unity Technologies

    Joined:
    Aug 16, 2017
    Posts:
    896
    @Guirao that's 100% a different issue. Your game is GPU / Render Thread, or vSync bound is all. Please check the Profiler documentation for Common samples, check timeline view, profile a build and open a different thread if you still think this is an issue with the Editor.
     
  6. P0150N

    P0150N

    Joined:
    Aug 1, 2015
    Posts:
    8
    Hi jonathans42,

    It happens on any project, I was able to replicate it just from creating a new empty scene project.

    However, since you did mention something about infinite repaints of windows, it might just be an arch + i3 - related issue, since those are not supported by Unity.
     
  7. GGraca

    GGraca

    Joined:
    Oct 13, 2015
    Posts:
    1
    A similar thing happens to me with Arch + Sway (window manager inspired by i3).

    Editor Loop is taking 1s but only if I have an editor window in another workspace, not visible to the user.

    Closing the other editor window, moving it to the same workspace or moving it to another workspace, visible in a secondary screen, fixes it and brings the FPS from <10 back to 200 in my case.
     
  8. jooleanlogic

    jooleanlogic

    Joined:
    Mar 1, 2018
    Posts:
    371
    I don't know if it's same problem but I just installed 2020.1.0b7 and get all cores fluctuating around 20% just sitting in the editor.
    I don't have this problem with my 19.3b install though so I think this is something new to 2020.
    If I open the Help->About and then close it, I end up with one core permanently at 100%.
    Mint 19.3, 3700x
     
  9. jaredgaul-ics

    jaredgaul-ics

    Joined:
    Jul 25, 2019
    Posts:
    1
    I ran into a similar issue today in 2020.1.0b8 where all of a sudden my project wouldn't run over 70fps. Usually it's in the hundreds of fps. Profiler showed a heavy editor loop hogging everything.Clicking Layout -> Revert Factory Settings fixed it for me.
     
  10. Lopost

    Lopost

    Joined:
    Aug 10, 2017
    Posts:
    5
    Hey, have you solved this problem?
     
  11. BySGI

    BySGI

    Joined:
    Aug 31, 2017
    Posts:
    1
    Hi @MartinTilo,
    i have in EditorLoop time ms 25973. Every expectation complicates development. Perhaps you can suggest the reason for this expectation?
     

    Attached Files:

  12. toyhunter

    toyhunter

    Joined:
    Mar 5, 2018
    Posts:
    41
    @P0150N Amazing, your #2 solution instantly works on my project on Unity 2020.1.5f1
    Unity fellows it would be great if we could test/optimize our game performance while isolating/disabling the editor itself during profiling.

    [Edited] Further it lower the CPU consumption of Unity3D in my MacOS (MBP 16 inch) from 13x% to around 50%
     
    Last edited: Sep 15, 2020
  13. tbillington

    tbillington

    Joined:
    May 6, 2020
    Posts:
    2
    Got this too on 2020.2 beta. Nothing going on script wise, 110~ms frame time, profiler just shows "Other" as taking 99% of the time, not obvious what's going on.
     
unityunity