Search Unity

  1. Are you interested in providing feedback directly to Unity teams? Sign up to become a member of Unity Pulse, our new product feedback and research community.
    Dismiss Notice

Editor issues with 5.2.0 on Windows 10 - rendering glitches

Discussion in 'Editor & General Support' started by shane1090, Sep 14, 2015.

  1. shane1090

    shane1090

    Joined:
    Oct 16, 2013
    Posts:
    5
    I've just downloaded the latest version of Unity and loaded up my project and I've noticed a few issues with the editor and various parts of it not rendering correctly. The attached shots show the Animation editor when trying to add a new property. It just keeps rendering the options over the top of what was there previously making a mess. The other is when clicking into 'External Tools' in the preferences window. I also tried creating a new project to see if it was my old project causing this but it happens with a new blank project too.

    This is running on Windows 10 Home. Anyone else having similar issues and might have a suggestion for fixing it?
     

    Attached Files:

  2. Baste

    Baste

    Joined:
    Jan 24, 2013
    Posts:
    5,529
    I've got a bunch of issues where windows are not redrawn properly - such as the inspector not showing changed values before i resize it, or the game window updating once a second even if the game is running at 300+ fps.

    But I've not got your errors, no. I'm suspecting that the issues are similar, though.
     
  3. shane1090

    shane1090

    Joined:
    Oct 16, 2013
    Posts:
    5
    Finally figured out what was causing the issue. I've got a few programs that are launched at startup to do with my motherboard - one of them being Nahimic (http://gaming.msi.com/features/nahimic) - some software used for audio. Forcing that close and reopening Unity fixed all the rendering issues with the editor. Not sure why it was causing any issues at all but for anyone else that may be experiencing similar issues, closing it worked. Phew!
     
  4. Drowning-Monkeys

    Drowning-Monkeys

    Joined:
    Mar 6, 2013
    Posts:
    328
    So, I'm suffering from the same issue, I have a brand new install with an ASUS Maximus VIII Hero. I've also pinned it down to something in my system tray, so as soon as i figure out which app it is, i'll update the post.
     
    Last edited: Sep 15, 2015
  5. Drowning-Monkeys

    Drowning-Monkeys

    Joined:
    Mar 6, 2013
    Posts:
    328
    Yup, my problem is the same. Sonic Studio is causing all my issues
     
  6. Rich0

    Rich0

    Joined:
    Aug 9, 2013
    Posts:
    50
    shane1090 - Wonderful! Thanks very much for this, I've also got a new MSI Notebook with Nahimic installed, had the same experience as you & closing Nahimic fixed the problem. Thank you very much!
     
  7. derkoi

    derkoi

    Joined:
    Jul 3, 2012
    Posts:
    2,084
    Yup same here. Damn
     
  8. mbuck

    mbuck

    Joined:
    Apr 18, 2015
    Posts:
    1
    Thank you Shane1090. You saved me some frustration.
     
  9. drswoboda

    drswoboda

    Joined:
    Nov 2, 2012
    Posts:
    18
    This thread has saved my week. I have been having a terrible time with Unity 5.3.5f1 on my new ASUS G752VL laptop. The interface glitches and there is a pause/stutter/hiccup when running the game for testing. It was a total deal breaker. I tried every Nvidia driver available to no avail. I was about ready to call ASUS and return this laptop since Unity is a major app I need to run on it.

    But Drowning Monkeys saved my day.

    I shutdown Sonic Studio II, loaded Unity and my project and all the glitches and pausing is GONE!

    So, now who do we try to tell about this issue, the Folks here on Unity forums and/or ASUS and the Sonic Studio devs?

    For now I am uninstalling Sonic Studio II on my ASUS G752VL and getting back to working with Unity without feeling like I want to tear out all my hair.

    Thank you folks for this thread...
     
  10. drswoboda

    drswoboda

    Joined:
    Nov 2, 2012
    Posts:
    18
unityunity