Search Unity

Editor Font is strange on latest 5.3

Discussion in '5.3 Beta' started by hawken, Nov 15, 2015.

  1. hawken

    hawken

    Joined:
    Aug 22, 2013
    Posts:
    475
    My main machine is in the shop for repairs, so installing this on my 10.9.5 iMac.

    Something is seriously wrong.

    Tried installing on my 10.9.5 laptop and everything was fine. - capital letters are sometimes missing in editor font.

    I'm guessing this is a graphics card issue?
    This iMac runs an ATI Radeon HD 4670 256 MB
    The laptop runs an NVIDIA GeForce. (macbook)

    5.2 runs fine.

    This problem affects the entire Unity interface.
     

    Attached Files:

    Last edited: Nov 15, 2015
  2. Alex-Lian

    Alex-Lian

    Guest

    This is RC1? Can you try with --force-opengl to see if going back to the legacy works?
     
  3. hawken

    hawken

    Joined:
    Aug 22, 2013
    Posts:
    475
    Hi, I'd love to, I don't know what this means though. Can you explain a little?

    Also, looks like I spoke too soon, the captial letters are missing from the Unity editor system font on my macbook.
     
  4. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    Happened to me also on Beta 6 using MacOSX El Capitan
    Its not constant but happens.
     
  5. Alex-Lian

    Alex-Lian

    Guest

    A fairly big effort to address the opengl core changes was done in RC1 (f1). If still present, please let us know, particularly if you do the command line start of --force-opengl improves things.
     
  6. Alex-Lian

    Alex-Lian

    Guest

    Are you on the latest release just released today? (the RC1 question). The second part is starting Unity with a command line option to use the legacy OpenGL system to see if the problem is with the updated one.
     
  7. hawken

    hawken

    Joined:
    Aug 22, 2013
    Posts:
    475
    The version I grabbed was today but not sure how to check if it's "RC1" (where would one find this?) It's 5.3.0f1
    Tried to run unity with command line in terminal, using "--force-opengl" but get "
    open: unrecognized option `--force-opengl'"

    any advice welcomed.
     
  8. hawken

    hawken

    Joined:
    Aug 22, 2013
    Posts:
    475
    @Alex Lian Ah. I think I have this figured out, for the uninitiated (like me) you'll need to do the following:

    Open terminal. Right click on Unity5.3 and show package contents, navigate to MacOS > Unity, drag that file in to terminal, then type --force-opengl after and hit enter.

    (not "open /path/ --force-opengl")
     
  9. greggtwep16

    greggtwep16

    Joined:
    Aug 17, 2012
    Posts:
    1,511
    For me it is definitely still an issue in RC1. I've opened case 744741. Everything is unusable and doesn't render correctly when using it like normal. Launching it with --force-opengl it then renders fine again, but launching even an empty project without the legacy flags has major rendering issues and is not usable.
     
  10. hawken

    hawken

    Joined:
    Aug 22, 2013
    Posts:
    475
    I got a chance to try with --force-opengl.

    Sadly it causes a lot of artifacts (flashing sprites, things disappear, render to texture is broken) in the Game view at runtime.