Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Editing Timeline's package code - .asmdef issues?

Discussion in 'Timeline' started by kogtech7, Jun 18, 2019.

  1. kogtech7

    kogtech7

    Joined:
    Jul 31, 2017
    Posts:
    7
    Recently, I decided to take matters into my own hands and the add right-click functionality I need to Timeline. I appreciate how you guys made the code open source.

    So I add the editor and runtime Timeline scripts to my project... but am unable to create a two-way dependency between my code and Timeline's. For that, I must delete the Assembly Definition files inside Timeline (because circular dependencies are not allowed).

    But if I delete the Assembly Definition files, I get four protection errors with internal Unity classes.

    This is with Unity 2019.2.0b5 and Timeline 1.1.0. Is there a way around this?
     
  2. seant_unity

    seant_unity

    Unity Technologies

    Joined:
    Aug 25, 2015
    Posts:
    1,007
    The only way around it is to move your code into the same assembly as Timeline.
     
    kogtech7 likes this.